aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2021-05-07 08:26:52 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-05-10 16:47:04 +0000
commit073b0aa8a4304190cd1727cee1393d39fd520a8b (patch)
tree759fa217d2e12612870c3cbdd00691945864d2b4 /Mk
parent14d57ad6df82b4e05148d63ff8839893a3405a12 (diff)
downloadports-073b0aa8a4304190cd1727cee1393d39fd520a8b.tar.gz
ports-073b0aa8a4304190cd1727cee1393d39fd520a8b.zip
overlay: allow to load -overlay.mk files for each USES
This will be done before the loading of the actual USES, it allows one to keep using the USES from the ports tree, and still provide additional features in the overlay
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 13785ff0f234..49dcd31afbba 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1464,6 +1464,9 @@ ${_f}_ARGS:= ${f:C/^[^\:]*(\:|\$)//:S/,/ /g}
.for f in ${USES}
.undef _usefound
.for udir in ${OVERLAYS:C,$,/Mk/Uses,} ${USESDIR}
+# always include all overlay files found in each overlay
+_overlayfile= ${udir}/${f:C/\:.*//}-overlay.mk
+.sinclude "${_overlayfile}
_usefile= ${udir}/${f:C/\:.*//}.mk
.if exists(${_usefile}) && !defined(_usefound)
_usefound=