aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2020-09-28 13:46:43 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2020-09-28 13:46:43 +0000
commit2922bb2e6b8228e5b973817ef950dfb39f070566 (patch)
tree4ce1a3eec2920a72050fb7cffb72fbdf431cc462 /Mk
parent45ce1db62d63af49f34f57b85f46116105c5bac4 (diff)
downloadports-2922bb2e6b8228e5b973817ef950dfb39f070566.tar.gz
ports-2922bb2e6b8228e5b973817ef950dfb39f070566.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index aa8c06bc2ded..9c61b8c3bc3f 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -5134,7 +5134,12 @@ install-desktop-entries:
.if !target(create-binary-alias)
create-binary-alias: ${BINARY_LINKDIR}
.for target src in ${BINARY_ALIAS:C/=/ /}
- @${RLN} `which ${src}` ${BINARY_LINKDIR}/${target}
+ @if srcpath=`which -- ${src}`; then \
+ ${RLN} $${srcpath} ${BINARY_LINKDIR}/${target}; \
+ else \
+ ${ECHO_MSG} "===> Missing \"${src}\" to create a binary alias at \"${BINARY_LINKDIR}/${target}\""; \
+ ${FALSE}; \
+ fi
.endfor
.endif
.endif