aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-18 21:44:41 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-18 22:07:08 +0000
commit2bb087ae1291834566f42137cb06b37990d6cbae (patch)
treeb581d02c2d9a8f6765418d769fa5181463ab859f /Mk
parent83885fe63bcb9aa7b140eba3425e82739f4734b3 (diff)
downloadports-2bb087ae1291834566f42137cb06b37990d6cbae.tar.gz
ports-2bb087ae1291834566f42137cb06b37990d6cbae.zip
Mk/bsd.ruby.mk: Clean up unused RUBY_REQUIRE
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.ruby.mk23
1 files changed, 0 insertions, 23 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index a70cc4cab026..b933608d0f6b 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -37,12 +37,6 @@ Ruby_Include_MAINTAINER= ruby@FreeBSD.org
# build.
# RUBY_SETUP - Set to the alternative name of setup.rb
# (default: setup.rb).
-# RUBY_REQUIRE - Set to a Ruby expression to evaluate before building
-# the port. The constant "Ruby" is set to the integer
-# version number of ruby, and the result of the
-# expression will be set to RUBY_PROVIDED, which is
-# left undefined if the result is nil, false or a
-# zero-length string. Implies USE_RUBY.
# USE_RUBYGEMS - Do not use this -- instead USES=gem
#
# [variables that each port should not (re)define]
@@ -293,23 +287,6 @@ PLIST_SUB+= ${PLIST_RUBY_DIRS:C,DIR="(${LOCALBASE}|${PREFIX})/,DIR=",} \
RUBY27=${RUBY27} \
RUBY30=${RUBY30}
-# require check
-.if defined(RUBY_REQUIRE)
-USE_RUBY= yes
-
-.if exists(${RUBY})
-RUBY_PROVIDED!= ${RUBY} -e '\
- Ruby = ${RUBY_RELVERSION_CODE}; \
- value = begin; ${RUBY_REQUIRE}; end and puts value'
-.else
-RUBY_PROVIDED= "should be" # the latest version is going to be installed
-.endif
-
-.if empty(RUBY_PROVIDED)
-.undef RUBY_PROVIDED
-.endif
-.endif
-
.if ${PORT_OPTIONS:MDEBUG}
RUBY_FLAGS+= -d
.endif