aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-02-24 20:45:14 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-02-24 20:45:14 +0000
commit2e6999b9c0aff4bbd6d029536aa73eb94fb83345 (patch)
tree170762af3fc314b5e167a88ca8796ead4fc6f656 /Mk
parent33be1686eda6522d76c0746b2508ef93a5b83cef (diff)
downloadports-2e6999b9c0aff4bbd6d029536aa73eb94fb83345.tar.gz
ports-2e6999b9c0aff4bbd6d029536aa73eb94fb83345.zip
Fix Qt5 ports
Thanks to antoine@ for figuring out that ${REINPLACE_CMD} does not handle '\t' in all supported versions -- so replacing the tabs in the script kept the tabs, but called /usr/bin/ca and /usr/bin/sor instead. Switched to indenting with spaces instead, so and only strip leading spaces at that, so the scripts can be slightly easier to indent / layout. Add comment pointing out how to easily read the shellscript among all the minifying-magic. danfe@ pointed to a naming mix-up; because the variables were used consistently, this had no effect but a weirdly-named temporary file in ${WRKSRC}. Swapped the names the right way around. Bump PORTREVISION on qt5-core again to force another round of rebuilds. Reported by: danfe, antoine
Notes
Notes: svn path=/head/; revision=566508
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/qt-dist.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/Mk/Uses/qt-dist.mk b/Mk/Uses/qt-dist.mk
index 6b91e0fc313e..9b2d76cfe104 100644
--- a/Mk/Uses/qt-dist.mk
+++ b/Mk/Uses/qt-dist.mk
@@ -197,8 +197,8 @@ QT_CONFIG?= # For *.pri files QT_CONFIG flags.
. if ${QT_DEFINES}
QMAKE_ARGS+= DEFINES+="${QT_DEFINES:O:u:C/^([^-])/QT_\1/:C/^-/QT_NO_/:O}"
. endif # ${QT_DEFINES}
-PKGDEINSTALL= ${WRKDIR}/pkg-install
-PKGINSTALL= ${WRKDIR}/pkg-deinstall
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+PKGINSTALL= ${WRKDIR}/pkg-install
. if ${QT_CONFIG:N-*}
QMAKE_ARGS+= QT_CONFIG+="${QT_CONFIG:N-*:O:u}"
. endif
@@ -391,7 +391,8 @@ qt-post-install:
${WRKDIR}/pkg-change.tmp
@${SED} -e 's,@install,,' -e 's,@deinstall,##,' ${WRKDIR}/pkg-change.tmp | ${SED} -e '/##/d' > ${PKGINSTALL}
@${SED} -e 's,@install,##,' -e 's,@deinstall,,' ${WRKDIR}/pkg-change.tmp | ${SED} -e '/##/d' > ${PKGDEINSTALL}
- @${REINPLACE_CMD} 's/\t//g' ${PKGINSTALL} ${PKGDEINSTALL}
+ # Drop all leading spaces in the script, to minify
+ @${REINPLACE_CMD} 's/^ *//' ${PKGINSTALL} ${PKGDEINSTALL}
. if ${QT_DEFINES:N-*}
@${MKDIR} ${STAGEDIR}${QT_INCDIR}/QtCore/modules
@${ECHO_CMD} -n \