aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-01-10 13:44:54 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-01-10 13:44:54 +0000
commit3199a3d84ef99fd521006ed87f2c9717d2cf782a (patch)
tree666fa5367d5d650a2f22a84078587412790ccc60 /Mk
parent8ff2fb8c2c88e000fb4abd3cef0c5c09d1e42560 (diff)
downloadports-3199a3d84ef99fd521006ed87f2c9717d2cf782a.tar.gz
ports-3199a3d84ef99fd521006ed87f2c9717d2cf782a.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/tcl.mk10
-rw-r--r--Mk/Uses/tk.mk4
2 files changed, 9 insertions, 5 deletions
diff --git a/Mk/Uses/tcl.mk b/Mk/Uses/tcl.mk
index 4d0a376c7e8c..2c528f09df0f 100644
--- a/Mk/Uses/tcl.mk
+++ b/Mk/Uses/tcl.mk
@@ -57,7 +57,13 @@
# Build-time / Run-time only dependencies can be specified with build or run.
#
-.if !defined(_INCLUDE_USES_TCL_MK)
+.if ${USES:Mtk} || ${USES:Mtk\:*}
+.if !defined(_TCLTK_PORT)
+_TCLTK_IGNORE= yes
+.endif
+.endif
+
+.if !defined(_INCLUDE_USES_TCL_MK) && !defined(_TCLTK_IGNORE)
_INCLUDE_USES_TCL_MK= yes
#
@@ -200,3 +206,5 @@ LIB_DEPENDS+= ${_TCLTK_LIB_LINE}
.endif
.endif # defined(_INCLUDE_USES_TCL_MK)
+
+.undef _TCLTK_IGNORE
diff --git a/Mk/Uses/tk.mk b/Mk/Uses/tk.mk
index d3f82a61d96b..7525499c12be 100644
--- a/Mk/Uses/tk.mk
+++ b/Mk/Uses/tk.mk
@@ -4,10 +4,6 @@
#
#
-.if ${USES:Mtcl} || ${USES:Mtcl\:*}
-IGNORE= Do not set both tcl and tk in USES
-.endif
-
.if defined(tk_ARGS)
tcl_ARGS:= ${tk_ARGS}
.endif