aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2024-04-23 17:11:39 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2024-05-07 01:42:21 +0000
commit604adf973a514f8fc8dc550ebd884ae5ce9a6e82 (patch)
tree3e87a74e28780b89b1cb4fb0b63fbe8380ee1630 /Mk
parentb3b6a064559c17d7a38fb10321cd78ac115d41e9 (diff)
downloadports-604adf973a514f8fc8dc550ebd884ae5ce9a6e82.tar.gz
ports-604adf973a514f8fc8dc550ebd884ae5ce9a6e82.zip
Emacs: Add new wayland flavor
Emacs requires mutually exclusive build parameters depending on whether the user is running under X11 or Wayland. Rather than require either set of users to build a custom package, create a new wayland flavor, and use default options appropriate for users running under X. PR: 278167 Reviewed by: ashish, jbeich Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D44917
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/emacs.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/Uses/emacs.mk b/Mk/Uses/emacs.mk
index d601390f0569..8161e980491b 100644
--- a/Mk/Uses/emacs.mk
+++ b/Mk/Uses/emacs.mk
@@ -79,7 +79,7 @@ _EMACS_RUN_DEP= yes
# Only set FLAVORS when...
. if defined(_EMACS_RUN_DEP) && !defined(_EMACS_NOFLAVORS)
-FLAVORS= full canna nox devel_full devel_nox
+FLAVORS= full canna nox wayland devel_full devel_nox
# Sort the default to be first
. if defined(EMACS_DEFAULT)
FLAVORS:= ${EMACS_DEFAULT} ${FLAVORS:N${EMACS_DEFAULT}}