aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2021-02-04 14:35:22 +0000
committerMathieu Arnold <mat@FreeBSD.org>2021-02-04 14:35:22 +0000
commit6a834798621f35b02edf39aecd018aa09470345d (patch)
tree82a796b4734fe1e65fdc42cf462bfe1db4111563 /Mk
parent878fe059596cec4d0ad707354f4521c36295433c (diff)
downloadports-6a834798621f35b02edf39aecd018aa09470345d.tar.gz
ports-6a834798621f35b02edf39aecd018aa09470345d.zip
Make USES=python without argument mean 3.6+.
This is getting us one step further to deorbitting Python 2.7. Reviewed by: rene, antoine, swills Differential Revision: https://reviews.freebsd.org/D28459
Notes
Notes: svn path=/head/; revision=564032
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/python.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index 4dbee4f6dbc7..8fe19724fde7 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -22,12 +22,12 @@
# USES=python:3.6+ # Supports Python 3.6 or later
# USES=python:3.6-3.9 # Supports Python 3.6 to 3.9
# USES=python:-3.8 # Supports Python up to 3.8
-# USES=python # Supports any/all Python versions
+# USES=python # Supports 3.6+
#
# NOTE: <version-spec> should be as specific as possible, matching the versions
# upstream declares support for, without being incorrect. In particular,
-# USES=python *without* a <version-spec> means any and all past or future
-# versions, including unreleased versions, which is probably incorrect.
+# USES=python *without* a <version-spec> means 3.6+,
+# including unreleased versions, which is probably incorrect.
#
# Not specifying a <version-spec> should only be used when a more specific
# <version-spec> cannot be specified due to syntax limitations, for
@@ -334,6 +334,10 @@ DEV_ERROR+= "USES=python:3 is no longer supported, use USES=python:3.6+ or an a
_PYTHON_VERSION:= ${PYTHON_DEFAULT}
+.if empty(_PYTHON_ARGS)
+_PYTHON_ARGS= 3.6+
+.endif
+
# Validate Python version whether it meets the version restriction.
_PYTHON_VERSION_CHECK:= ${_PYTHON_ARGS:C/^([1-9]\.[0-9])$/\1-\1/}
_PYTHON_VERSION_MINIMUM_TMP:= ${_PYTHON_VERSION_CHECK:C/([1-9]\.[0-9])[-+].*/\1/}