aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2021-07-12 19:35:58 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2021-07-12 19:35:58 +0000
commit6b641f4eb46bba486b2664d0c9ffd992d035cd2a (patch)
treec60cfa86c4254944d80043f42e957afe4b3c7d48 /Mk
parent76eed7c913cbf4ee12f27a133724ef7ec50cba02 (diff)
downloadports-6b641f4eb46bba486b2664d0c9ffd992d035cd2a.tar.gz
ports-6b641f4eb46bba486b2664d0c9ffd992d035cd2a.zip
Mk: Document and simply user-modifiable ccache vars
PR: 242944
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.ccache.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/Mk/bsd.ccache.mk b/Mk/bsd.ccache.mk
index 94badb01174c..0cfdd7b594bb 100644
--- a/Mk/bsd.ccache.mk
+++ b/Mk/bsd.ccache.mk
@@ -3,7 +3,8 @@
#
# WITH_CCACHE_BUILD=yes enables depending on ccache and using it in the build.
# NO_CCACHE_DEPEND will additionally not add the dependency on ccache.
-# NO_CCACHE will disable this entirely.
+# NO_CCACHE will disable using ccache entirely.
+# CCACHE_PREFIX is where ccache is already installed. Default: LOCALBASE
COMMANDS_Include_MAINTAINER= portmgr@FreeBSD.org
@@ -36,8 +37,9 @@ WARNING+= WITH_CCACHE_BUILD support disabled, please set CCACHE_DIR.
BUILD_DEPENDS+= ${LOCALBASE}/bin/ccache:devel/ccache
. endif
-CCACHE_WRAPPER_PATH?= ${LOCALBASE}/libexec/ccache
-CCACHE_BIN?= ${CCACHE_WRAPPER_PATH:C,/libexec/ccache$,,}/bin/ccache
+CCACHE_PREFIX?= ${LOCALBASE}
+CCACHE_WRAPPER_PATH?= ${CCACHE_PREFIX}/libexec/ccache
+CCACHE_BIN?= ${CCACHE_PREFIX}/bin/ccache
.if exists(${CCACHE_WRAPPER_PATH})
# Prepend the ccache dir into the PATH and setup ccache env