aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-05-30 20:50:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-05-30 20:50:05 +0000
commit738eb15d736491dc2dd07ecad6304f1484933266 (patch)
tree7e4bf8320eddb59378dbd3be06f728646163d107 /Mk
parent17091cda9dea3643658c7cbcdf4183d3ab471902 (diff)
downloadports-738eb15d736491dc2dd07ecad6304f1484933266.tar.gz
ports-738eb15d736491dc2dd07ecad6304f1484933266.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.options.desc.mk6
-rw-r--r--Mk/bsd.port.mk14
2 files changed, 9 insertions, 11 deletions
diff --git a/Mk/bsd.options.desc.mk b/Mk/bsd.options.desc.mk
index 9c1376501a5e..73cf342a20bb 100644
--- a/Mk/bsd.options.desc.mk
+++ b/Mk/bsd.options.desc.mk
@@ -2,8 +2,6 @@
#
# READ BEFORE EDITING:
# - Please keep descriptions sorted alphabetically by variable name.
-# - Do not forget to wrap the description with double quotes if it contains
-# parentheses or single quotes.
#
Options_Desc_MAINTAINER= ports@FreeBSD.org
@@ -32,7 +30,7 @@ EXAMPLES_DESC?= Build and install the examples
EXPAT_DESC?= Enable Expat support
FAAC_DESC?= Enable FAAC encoder support
FAAD_DESC?= Enable FAAD aac decoder support
-FFMPEG_DESC?= "Support FFMPEG (wma aiff ac3 ape...)"
+FFMPEG_DESC?= Support FFMPEG (wma aiff ac3 ape...)
FLAC_DESC?= Enable support for flac
FONTCONFIG_DESC?= Enable Font configuration API for X
FPECTL_DESC?= Enable floating point exception handling
@@ -100,7 +98,7 @@ PRINT_DESC?= Enable Printer support
PROJ_DESC?= Enable PROJ.4 support
PTH_DESC?= Enable GNU Pth for threading/multiprocessing
PULSEAUDIO_DESC?= Support PulseAudio sound server
-PYMALLOC_DESC?= "Enable python's internal malloc"
+PYMALLOC_DESC?= Enable python's internal malloc
PYTHON_DESC?= Enable Python binding/support
QT4_DESC?= Enable Qt4 gui toolkit support
RAW_DESC?= Enable RAW support
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index eedeef38e276..ed43d76ace4d 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -6006,9 +6006,9 @@ DEFOPTIONS+= ${opt} "${${opt}_DESC:S|"||g:S|'| |g}" on
. for opt in ${OPTIONS_MULTI_${multi}}
_COMPLETE_OPTIONS_LIST+= ${opt}
. if empty(PORT_OPTIONS:M${opt})
-DEFOPTIONS+= ${opt} "M(${multi}): ${${opt}_DESC}" off
+DEFOPTIONS+= ${opt} "M(${multi}): ${${opt}_DESC:S|"||g:S|'| |g}" off
. else
-DEFOPTIONS+= ${opt} "M(${multi}): ${${opt}_DESC}" on
+DEFOPTIONS+= ${opt} "M(${multi}): ${${opt}_DESC:S|"||g:S|'| |g}" on
. endif
. endfor
.endfor
@@ -6016,9 +6016,9 @@ DEFOPTIONS+= ${opt} "M(${multi}): ${${opt}_DESC}" on
. for opt in ${OPTIONS_SINGLE_${single}}
_COMPLETE_OPTIONS_LIST+= ${opt}
. if empty(PORT_OPTIONS:M${opt})
-DEFOPTIONS+= ${opt} "S(${single}): ${${opt}_DESC}" off
+DEFOPTIONS+= ${opt} "S(${single}): ${${opt}_DESC:S|"||g:S|'| |g}" off
. else
-DEFOPTIONS+= ${opt} "S(${single}): ${${opt}_DESC}" on
+DEFOPTIONS+= ${opt} "S(${single}): ${${opt}_DESC:S|"||g:S|'| |g}" on
. endif
. endfor
.endfor
@@ -6110,7 +6110,7 @@ showconfig:
@${ECHO_MSG} -n " ${opt}=on"
. endif
. if !empty(${opt}_DESC)
- @${ECHO_MSG} -n ": "${${opt}_DESC}
+ @${ECHO_MSG} -n ": "${${opt}_DESC:Q}
. endif
@${ECHO_MSG} ""
.endfor
@@ -6124,7 +6124,7 @@ showconfig:
@${ECHO_MSG} -n " ${opt}=on"
. endif
. if !empty(${opt}_DESC)
- @${ECHO_MSG} -n ": "${${opt}_DESC}
+ @${ECHO_MSG} -n ": "${${opt}_DESC:Q}
. endif
@${ECHO_MSG} ""
. endfor
@@ -6140,7 +6140,7 @@ showconfig:
@${ECHO_MSG} -n " ${opt}=on"
. endif
. if !empty(${opt}_DESC)
- @${ECHO_MSG} -n ": "${${opt}_DESC}
+ @${ECHO_MSG} -n ": "${${opt}_DESC:Q}
. endif
@${ECHO_MSG} ""
. endfor