aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2024-04-09 06:26:41 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2024-04-09 06:36:33 +0000
commit754b2ef182b8622b129c78bd86993393f40345a0 (patch)
tree79d02c96c20989c012d67591105ac71c85d06beb /Mk
parentb884c7812e68a7c2bd939a9e4faaff38cbccd0a7 (diff)
downloadports-754b2ef182b8622b129c78bd86993393f40345a0.tar.gz
ports-754b2ef182b8622b129c78bd86993393f40345a0.zip
Mk/Uses/tcl.mk: remove support for Tcl/Tk 8.5
In preparation for removing the lang/tcl85 and x11-toolkits/tk85 ports. The 8.5 series is EOL. PR: 278098 Approved by: antoine (portmgr, exp-run)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/tcl.mk19
1 files changed, 5 insertions, 14 deletions
diff --git a/Mk/Uses/tcl.mk b/Mk/Uses/tcl.mk
index d940b4a19409..eb47dfea7bbf 100644
--- a/Mk/Uses/tcl.mk
+++ b/Mk/Uses/tcl.mk
@@ -38,11 +38,11 @@
# is installed, bring in the default version. See
# ${_TCLTK_DEFAULT_VERSION} below.
#
-# - 85, 86, 87 - Depend on a specific version series of PORT. Multiple
+# - 86, 87 - Depend on a specific version series of PORT. Multiple
# values are OK. The highest version available is
# picked.
#
-# - 85+, 86+, 87+ - Depend on any installed version greater or equal to
+# - 86+, 87+ - Depend on any installed version greater or equal to
# the specified version.
#
# If wrapper is specified, an additional dependency on tcl-wrapper or
@@ -71,7 +71,7 @@ _INCLUDE_USES_TCL_MK= yes
#
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
-_TCLTK_VALID_VERSIONS= 85 86 87
+_TCLTK_VALID_VERSIONS= 86 87
#
# Bring in the default and check that the specified version is in the list of
@@ -94,16 +94,13 @@ _TCLTK_PORT?= tcl
. if ${tcl_ARGS:M*+}
_TCLTK_MIN_VERSION:= ${tcl_ARGS:M*+:S/+//}
_TCLTK_WANTED_VERSIONS:=${_TCLTK_DEFAULT_VERSION}
-. if ${_TCLTK_MIN_VERSION} == "85"
-IGNORE= Minimum tcltk version 85+ is meaningless
-. endif
. endif
#
# Parse one or more ver arguments.
#
-. if ${tcl_ARGS:M8[5-7]}
-_TCLTK_WANTED_VERSIONS:=${tcl_ARGS:M8[5-7]}
+. if ${tcl_ARGS:M8[6-7]}
+_TCLTK_WANTED_VERSIONS:=${tcl_ARGS:M8[6-7]}
. endif
#
@@ -156,12 +153,6 @@ _TCLTK_WANTED_VERSION:= ${_TCLTK_HIGHEST_VERSION}
. endif
#
-# Deprecate by default all ports depending on 8.5
-. if ${_TCLTK_WANTED_VERSION} == "85"
-DEPRECATED= Tcl/Tk 8.5 is nearing EOL, please consider porting to Tcl/Tk 8.6
-. endif
-
-#
# Exported variables
#
TCL_VER:= ${_TCLTK_WANTED_VERSION:S/8/8./}