aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2018-06-22 22:21:29 +0000
committerRene Ladan <rene@FreeBSD.org>2018-06-22 22:21:29 +0000
commit99b35863e651e3942e6634735fa1f2179e731420 (patch)
tree9d0a4f79be8feb552591479599bbed7d17f0a681 /Mk
parentab24c7a4d6c1354edbc217cf0acaabcc69657a43 (diff)
downloadports-99b35863e651e3942e6634735fa1f2179e731420.tar.gz
ports-99b35863e651e3942e6634735fa1f2179e731420.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/gecko.mk21
-rw-r--r--Mk/bsd.gecko.mk2
2 files changed, 3 insertions, 20 deletions
diff --git a/Mk/Uses/gecko.mk b/Mk/Uses/gecko.mk
index 5cf120e5b794..7c7877ec3c7c 100644
--- a/Mk/Uses/gecko.mk
+++ b/Mk/Uses/gecko.mk
@@ -6,8 +6,7 @@
#
# Feature: gecko
# Usage: USES=gecko or USES=gecko:ARGS
-# Valid ARGS: libxul, firefox, seamonkey, thunderbird
-# in case the first argument is not libxul
+# Valid ARGS: firefox, seamonkey, thunderbird
# The following arguments are available
# - build: also add the dependency as a build
# dependency
@@ -18,23 +17,9 @@
.if !defined(_INCLUDE_USES_GECKO_MK)
_INCLUDE_USES_GECKO_MK= yes
-.if empty(gecko_ARGS)
-gecko_ARGS= libxul
-.endif
-
_GECKO_VERSION= ${gecko_ARGS:M[0-9][0-9]*}
-.if ${gecko_ARGS:Mlibxul}
-# Compat with older versions
-GECKO= libxul
-GECKO_CONFING?= ${LOCALBASE}/bin/${GECKO}-config
-XPIDL?= ${LOCALBASE}/lib/${GECKO}/xpidl
-XPIDL_INCL?= `${GECKO_CONFIG} --idlflags`
-
-BUILD_DEPENDS+= libxul>=45:www/libxul
-RUN_DEPENDS+= libxul>=45:www/libxul
-
-.elif ${gecko_ARGS:Mfirefox}
+.if ${gecko_ARGS:Mfirefox}
_GECKO_DEFAULT_VERSION= 60
_GECKO_VERSIONS= 60 61
@@ -78,7 +63,7 @@ _GECKO_INSTALLED_VER:= ${_GECKO_INSTALLED_VER:C/\..*//}
52_DEPENDS= ${LOCALBASE}/lib/thunderbird/thunderbird:mail/thunderbird
.else
-IGNORE= Unknown type of gecko dependency you may specify either libxul, firefox, seamonkey or thunderbird
+IGNORE= Unknown type of gecko dependency you may specify either firefox, seamonkey or thunderbird
.endif
.if defined(_GECKO_TYPE)
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 77c15842f3e6..c7574c11e800 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -89,9 +89,7 @@ USE_XORG= x11 xcomposite xdamage xext xfixes xrender xt
HAS_CONFIGURE= yes
CONFIGURE_OUTSOURCE= yes
-.if ${MOZILLA} != "libxul"
BUNDLE_LIBS= yes
-.endif
.if ${MOZILLA_VER:R:R} >= 49
USES+= compiler:c++14-lang