aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2021-03-22 15:13:49 +0000
committerMathieu Arnold <mat@FreeBSD.org>2021-03-22 15:13:49 +0000
commita19ab6e0a884c0f0c8e4a34269b7c5af1f6328f3 (patch)
tree8da9d47fef3fa7fc455244bdb6a8cee74902de24 /Mk
parent5907293b617cfe9de71ecb2fb20ff2a4e4fca303 (diff)
downloadports-a19ab6e0a884c0f0c8e4a34269b7c5af1f6328f3.tar.gz
ports-a19ab6e0a884c0f0c8e4a34269b7c5af1f6328f3.zip
Don't use an escape sequence when you can use a character class.
Using an escape sequence is more likely to get munged at some point while going through from make to sh to sed.
Notes
Notes: svn path=/head/; revision=568965
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 657cc7438f65..e67b9f7f27e9 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1761,7 +1761,7 @@ PLIST_SUB_SED_tmp2= ${PLIST_SUB_SED_tmp1:NEXTRACT_SUFX=*:NOSREL=*:NLIB32DIR=*:NP
PLIST_SUB_SED_tmp3?= ${PLIST_SUB_SED_tmp2:C/(${PLIST_SUB:M*_regex=*:C/_regex=.*/=.*/:Q:S/\\ /|/g:S/\\//g})//:C/(.*)_regex=(.*)/\1=\2/}
# Remove quotes
# Replace . with \. for later sed(1) usage
-PLIST_SUB_SED?= ${PLIST_SUB_SED_tmp3:C/([^=]*)="?([^"]*)"?/s!\2!%%\1%%!g;/g:C/\./\\./g}
+PLIST_SUB_SED?= ${PLIST_SUB_SED_tmp3:C/([^=]*)="?([^"]*)"?/s!\2!%%\1%%!g;/g:C/\./[.]/g}
# kludge to strip trailing whitespace from CFLAGS;
# sub-configure will not # survive double space