aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2022-05-13 16:37:50 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2022-06-08 16:24:35 +0000
commitbd70827c22827422583d9bd6963636ef4f2d5623 (patch)
treed227d18f0e4043a891ecb0fb18c2f15c2bde1ffc /Mk
parentd2153894e76837f45bc21c448f2c610f128ede7c (diff)
downloadports-bd70827c22827422583d9bd6963636ef4f2d5623.tar.gz
ports-bd70827c22827422583d9bd6963636ef4f2d5623.zip
devel/autoconf: update to 2.71
- Copy devel/autoconf to devel/autoconf2.69. - Update devel/autoconf to 2.71. - Allow ports to use 2.69 with USES=autoreconf:2.69. PR: 258046 Exp-run by: antoine
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/autoreconf.mk29
1 files changed, 23 insertions, 6 deletions
diff --git a/Mk/Uses/autoreconf.mk b/Mk/Uses/autoreconf.mk
index 7da3b85d5825..20cdbd588fa1 100644
--- a/Mk/Uses/autoreconf.mk
+++ b/Mk/Uses/autoreconf.mk
@@ -63,6 +63,7 @@
# Feature: autoreconf
# Usage: USES=autoreconf or USES=autoreconf:args
# Valid args: build Don't run autoreconf, only add build dependencies
+# 2.69 Use this legacy version
#
# MAINTAINER: ports@FreeBSD.org
@@ -70,7 +71,7 @@
_INCLUDE_USES_AUTORECONF_MK= yes
_USES_POST+= autoreconf
-AUTORECONF?= ${LOCALBASE}/bin/autoreconf
+AUTORECONF?= ${LOCALBASE}/bin/autoreconf${_AUTORECONF}
AUTORECONF_WRKSRC?= ${WRKSRC}
.endif
@@ -78,20 +79,37 @@ AUTORECONF_WRKSRC?= ${WRKSRC}
.if defined(_POSTMKINCLUDED) && !defined(_INCLUDE_USES_AUTORECONF_POST_MK)
_INCLUDE_USES_AUTORECONF_POST_MK= yes
-BUILD_DEPENDS+= autoconf>=2.69:devel/autoconf \
- automake>=1.16.1:devel/automake
+. if ${autoreconf_ARGS:M2.69}
+_AUTORECONF= 2.69
+BUILD_DEPENDS+= autoconf2.69>=2.69:devel/autoconf2.69
+. else
+_AUTORECONF= 2.71
+BUILD_DEPENDS+= autoconf>=2.71:devel/autoconf
+. endif
+
+BUILD_DEPENDS+= automake>=1.16.5:devel/automake
. if defined(libtool_ARGS) && empty(libtool_ARGS:Mbuild)
BUILD_DEPENDS+= libtoolize:devel/libtool
. endif
-. if empty(autoreconf_ARGS)
+# In case autoconf-switch wrapper scripts are used during build.
+CONFIGURE_ENV+= DEFAULT_AUTOCONF=${_AUTORECONF}
+MAKE_ENV+= DEFAULT_AUTOCONF=${_AUTORECONF}
+
+. if ${autoreconf_ARGS:Nbuild:N2.69}
+IGNORE= incorrect 'USES+=autoreconf:${autoreconf_ARGS}'\
+ expecting 'USES+=autoreconf[:build,2.69]'
+. endif
+
+. if ! ${autoreconf_ARGS:Mbuild}
_USES_configure+= 470:do-autoreconf
do-autoreconf:
. for f in AUTHORS ChangeLog INSTALL NEWS README
# Don't modify time stamps if the files already exist
@test -e ${AUTORECONF_WRKSRC}/${f} || ${TOUCH} ${AUTORECONF_WRKSRC}/${f}
. endfor
+. if ${_AUTORECONF} == 2.69
@(cd ${AUTORECONF_WRKSRC} && \
if test -f configure.ac; then configure=configure.ac; \
else configure=configure.in; fi && \
@@ -103,11 +121,10 @@ do-autoreconf:
then if ! ${LOCALBASE}/bin/intltoolize -f -c; then \
${ECHO_MSG} '===> Mk/Uses/autoreconf.mk: Error running intltoolize'; \
${FALSE}; fi; fi)
+. endif
@(cd ${AUTORECONF_WRKSRC} && if ! ${AUTORECONF} -f -i; then \
${ECHO_MSG} '===> Mk/Uses/autoreconf.mk: Error running ${AUTORECONF}'; \
${FALSE}; fi)
-. elif ! ${autoreconf_ARGS:Mbuild}
-IGNORE= Incorrect 'USES+=autoreconf:${autoreconf_ARGS}' expecting 'USES+=autoreconf[:build]'
. endif
.endif