aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-05-26 18:56:29 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-05-26 19:00:22 +0000
commitbd9b99277f42573d15ed4fd4eb9b83b62bc1cb0c (patch)
treeb6426fb7f7c66319a490828700fcfac5ab750251 /Mk
parent666d1280daf9dda5c5773b41ac60e005083daee9 (diff)
downloadports-bd9b99277f42573d15ed4fd4eb9b83b62bc1cb0c.tar.gz
ports-bd9b99277f42573d15ed4fd4eb9b83b62bc1cb0c.zip
Mk/Uses/scons.mk: Clean up after the removal of all scons:python2 usage
PR: 256170 Differential Revision: https://reviews.freebsd.org/D30472
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/scons.mk21
1 files changed, 5 insertions, 16 deletions
diff --git a/Mk/Uses/scons.mk b/Mk/Uses/scons.mk
index edb603ad7d8d..8c598a6983dc 100644
--- a/Mk/Uses/scons.mk
+++ b/Mk/Uses/scons.mk
@@ -1,30 +1,19 @@
# Provide support to use the scons
#
# Feature: scons
-# Usage: USES=scons[:ARGS]
-# Valid ARGS: python2 python3
-#
-# python2: Use default python 2.x to run scons
-# python3: Use default python 3.x to run scons (default)
+# Usage: USES=scons
+# Valid ARGS: none
#
# MAINTAINER: python@FreeBSD.org
.if !defined(_INCLUDE_USES_SCONS_MK)
_INCLUDE_USES_SCONS_MK= yes
-.if empty(scons_ARGS)
-scons_ARGS= python3
-.endif
+. if !empty(scons_ARGS)
+IGNORE+= USES=scons takes no arguments
+. endif
-.if ${scons_ARGS} == python3
_SCONS_PYTHON_VER= ${PYTHON3_DEFAULT}
-.elif ${scons_ARGS} == python2
-_SCONS_PYTHON_VER= ${PYTHON2_DEFAULT}
-DEPRECATED?= Uses Python 2.7 version of scons, and Python 2.7 which is EOLed upstream
-EXPIRATION_DATE?= 2020-12-31
-.else
-IGNORE= Incorrect 'USES+= scons:${scons_ARGS}' usage
-.endif
_SCONS_PYTHON_FLAVOR= py${_SCONS_PYTHON_VER:S|.||}