aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2021-07-12 19:49:53 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2021-07-12 19:49:53 +0000
commitbe98df0b75eaa77c0c7153f4b389adf6c34691ba (patch)
treeea0f623ca36d860c38d6c62f0938ffb1dff1120d /Mk
parent6feaf49e01d6dd6592a740c6d254b235e7f23860 (diff)
downloadports-be98df0b75eaa77c0c7153f4b389adf6c34691ba.tar.gz
ports-be98df0b75eaa77c0c7153f4b389adf6c34691ba.zip
Mk/bsd.ccache.mk: Rename CCACHE_PREFIX -> CCACHE_PKG_PREFIX
CCACHE_PREFIX already means something special to ccache. PR: 242944
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.ccache.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/Mk/bsd.ccache.mk b/Mk/bsd.ccache.mk
index 7bcb72b222af..cd8124c020d0 100644
--- a/Mk/bsd.ccache.mk
+++ b/Mk/bsd.ccache.mk
@@ -4,7 +4,7 @@
# WITH_CCACHE_BUILD=yes enables depending on ccache and using it in the build.
# NO_CCACHE_DEPEND will additionally not add the dependency on ccache.
# NO_CCACHE will disable using ccache entirely.
-# CCACHE_PREFIX is where ccache is already installed. Default: LOCALBASE
+# CCACHE_PKG_PREFIX is where ccache is already installed. Default: LOCALBASE
COMMANDS_Include_MAINTAINER= portmgr@FreeBSD.org
@@ -31,9 +31,9 @@ WARNING+= WITH_CCACHE_BUILD support disabled, please set CCACHE_DIR.
.if !defined(NO_CCACHE) && defined(WITH_CCACHE_BUILD) && !${CC:M*ccache*} && \
!defined(NO_BUILD)
-CCACHE_PREFIX?= ${LOCALBASE}
-CCACHE_WRAPPER_PATH?= ${CCACHE_PREFIX}/libexec/ccache
-CCACHE_BIN?= ${CCACHE_PREFIX}/bin/ccache
+CCACHE_PKG_PREFIX?= ${LOCALBASE}
+CCACHE_WRAPPER_PATH?= ${CCACHE_PKG_PREFIX}/libexec/ccache
+CCACHE_BIN?= ${CCACHE_PKG_PREFIX}/bin/ccache
# Avoid depends loops between ccache and pkg
. if !defined(NO_CCACHE_DEPEND) && \