aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-09-30 10:15:03 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-09-30 10:15:03 +0000
commitcd8d0d28887c85e356bbeefa40aa462f0983c64e (patch)
tree77e7a73909374f992b3bc24a614ba6eb4cd5c525 /Mk
parent9635c1b5d7f5323e0f2d710e948e60d5d8361740 (diff)
downloadports-cd8d0d28887c85e356bbeefa40aa462f0983c64e.tar.gz
ports-cd8d0d28887c85e356bbeefa40aa462f0983c64e.zip
Remove outdated USES=twisted
Notes
Notes: svn path=/head/; revision=450956
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/twisted.mk62
1 files changed, 0 insertions, 62 deletions
diff --git a/Mk/Uses/twisted.mk b/Mk/Uses/twisted.mk
deleted file mode 100644
index 348d1e569307..000000000000
--- a/Mk/Uses/twisted.mk
+++ /dev/null
@@ -1,62 +0,0 @@
-# $FreeBSD$
-#
-# Provide support for Twisted-related ports
-#
-# Feature: twisted
-# Usage: USES= twisted:build,run,compA,compB,...
-# Valid ARGS:
-# build Adds twisted and any additional component as build
-# dependency to the port
-# run Adds twisted and any additional component as run
-# dependency to the port
-# comp Adds the specified twisted component to as build or
-# run dependency to the ports
-#
-# If the build and run arguments are omitted, twisted or any specified
-# component will be added as build AND run dependency.
-#
-# The current supported components are:
-#
-# conch flow lore mail names news runner web web2 words
-#
-# MAINTAINER: python@FreeBSD.org
-
-.if !defined(_INCLUDE_USES_TWISTED_MK)
-_INCLUDE_USES_TWISTED_MK= yes
-
-# If neither build nor run are specified add both.
-.if ${twisted_ARGS:Mbuild} || empty(twisted_ARGS:Mrun)
-BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/twisted/__init__.py:devel/py-twistedCore
-.endif
-.if ${twisted_ARGS:Mrun} || empty(twisted_ARGS:Mbuild)
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/twisted/__init__.py:devel/py-twistedCore
-.endif
-
-_TWISTED_COMPONENTS= conch flow lore mail names news pair runner web web2 words
-
-conch_DEPENDS= ${PYTHON_SITELIBDIR}/twisted/conch/__init__.py:security/py-twistedConch
-flow_DEPENDS= ${PYTHON_SITELIBDIR}/twisted/flow/__init__.py:devel/py-twistedFlow
-lore_DEPENDS= ${PYTHON_SITELIBDIR}/twisted/lore/__init__.py:textproc/py-twistedLore
-mail_DEPENDS= ${PYTHON_SITELIBDIR}/twisted/mail/__init__.py:mail/py-twistedMail
-names_DEPENDS= ${PYTHON_SITELIBDIR}/twisted/names/__init__.py:dns/py-twistedNames
-news_DEPENDS= ${PYTHON_SITELIBDIR}/twisted/news/__init__.py:news/py-twistedNews
-pair_DEPENDS= ${PYTHON_SITELIBDIR}/twisted/pair/__init__.py:net/py-twistedPair
-runner_DEPENDS= ${PYTHON_SITELIBDIR}/twisted/runner/__init__.py:devel/py-twistedRunner
-web2_DEPENDS= ${PYTHON_SITELIBDIR}/twisted/web2/__init__.py:www/py-twistedWeb2
-web_DEPENDS= ${PYTHON_SITELIBDIR}/twisted/web/__init__.py:www/py-twistedWeb
-words_DEPENDS= ${PYTHON_SITELIBDIR}/twisted/words/__init__.py:net-im/py-twistedWords
-
-.for component in ${twisted_ARGS:Nbuild:Nrun}
-. if ${_TWISTED_COMPONENTS:M${component}}==""
-IGNORE= cannot install unknown twisted component ${component}
-. endif
-# If neither build nor run are specified add both.
-. if ${twisted_ARGS:Mbuild} || empty(twisted_ARGS:Mrun)
-BUILD_DEPENDS+= ${${component}_DEPENDS}
-. endif
-. if ${twisted_ARGS:Mrun} || empty(twisted_ARGS:Mbuild)
-RUN_DEPENDS+= ${${component}_DEPENDS}
-. endif
-.endfor
-
-.endif # !defined(_INCLUDE_USES_TWISTED_MK)