aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-12-03 06:19:02 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-12-03 06:19:02 +0000
commite4e073af5745071495104e69e846f6f4e2aa0d9b (patch)
tree1c5cefbfc05cf8a39056b2eb2f95b53aba1a4b6b /Mk
parent4a2d86af6c899b094a48425de40addf716fe3fd4 (diff)
downloadports-e4e073af5745071495104e69e846f6f4e2aa0d9b.tar.gz
ports-e4e073af5745071495104e69e846f6f4e2aa0d9b.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gnustep.mk26
1 files changed, 1 insertions, 25 deletions
diff --git a/Mk/bsd.gnustep.mk b/Mk/bsd.gnustep.mk
index 1223df4a14af..0601f76554ad 100644
--- a/Mk/bsd.gnustep.mk
+++ b/Mk/bsd.gnustep.mk
@@ -23,21 +23,9 @@
# GNUSTEP_WITH_BASE_GCC=yes
# use system compiler (does not work on all architectures).
#
-# GNUSTEP_WITH_GCC32=yes
-# use gcc 3.2.x with objective C shared libraries.
-#
-# GNUSTEP_WITH_GCC33=yes
-# use gcc 3.3.x with objective C shared libraries.
-#
# GNUSTEP_WITH_GCC34=yes
# use gcc 3.4.x with objective C shared libraries (default).
#
-# GNUSTEP_WITH_GCC40=yes
-# use gcc 4.0.x with objective C shared libraries.
-#
-# GNUSTEP_WITH_GCC41=yes
-# use gcc 4.1.x with objective C shared libraries.
-#
# GNUSTEP_WITH_GCC42=yes
# use gcc 4.2.x with objective C shared libraries.
#
@@ -229,24 +217,12 @@ GNUSTEP_WITH_GCC42= yes
.endif
.endif
-.if defined(GNUSTEP_WITH_GCC32)
-GCCSUFFIX=32
-GNUSTEP_GCC_PORT?= lang/gcc-objc
-.endif
-.if defined(GNUSTEP_WITH_GCC33)
-GCCSUFFIX=33
-.endif
.if defined(GNUSTEP_WITH_GCC34)
GCCSUFFIX=34
.endif
-.if defined(GNUSTEP_WITH_GCC40)
-GCCSUFFIX=40
-.endif
-.if defined(GNUSTEP_WITH_GCC41)
-GCCSUFFIX=41
-.endif
.if defined(GNUSTEP_WITH_GCC42)
GCCSUFFIX=42
+BROKEN= objc support in gcc42 was removed
.endif
CC= gcc${GCCSUFFIX}
CXX= g++${GCCSUFFIX}