aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2021-07-21 12:19:56 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-07-21 12:23:04 +0000
commitec2764d5ec4933f52cb0718663f60f1e1b1eed7f (patch)
tree294c67b752db47b8389c95672b14b3cb646b24c0 /Mk
parent0367b81ce5a1a958596cffef026a59cda2ef03f9 (diff)
downloadports-ec2764d5ec4933f52cb0718663f60f1e1b1eed7f.tar.gz
ports-ec2764d5ec4933f52cb0718663f60f1e1b1eed7f.zip
Mk/bsd.port.mk: prepare the land for pkg 1.17
in next version of pkg, we now use a uniq extension: '.pkg' whatever the compression is, the problem is some bootstrap pkg(7) does not handle that yet, notably on freebsd 11.4 and 12.2. We already have a compatibility layer by creating a symlink on the old extension, which works but the signature itself will not exist with the old extension. Add a workaround in the ports tree to symlink the new signature to the old expected signature. Given at the moment we are doing that things are not yet signed by default we do create a dead symlink, but at the moment the repo are published the right signature will be there.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk11
1 files changed, 10 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 0fe16fa5426d..228644a1845f 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -2648,6 +2648,9 @@ PKGBASE?= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
PKGLATESTFILE= ${PKGLATESTREPOSITORY}/${PKGBASE}${PKG_SUFX}
.if ${WITH_PKG} == devel
PKGOLDLATESTFILE= ${PKGLATESTREPOSITORY}/${PKGBASE}${PKG_OLDSUFX}
+# Temporary workaround to be deleted once every supported version of FreeBSD
+# have a bootstrap which handles the pkg extension.
+PKGOLDSIGFILE= ${PKGLATESTREPOSITORY}/${PKGBASE}${PKG_OLDSUFX}.sig
.endif
CONFIGURE_SCRIPT?= configure
@@ -3447,10 +3450,16 @@ ${PKGLATESTFILE}: ${PKGFILE} ${PKGLATESTREPOSITORY}
${INSTALL} -l rs ${PKGFILE} ${PKGLATESTFILE}
.if ${WITH_PKG} == devel
-_EXTRA_PACKAGE_TARGET_DEP+= ${PKGOLDLATESTFILE}
+_EXTRA_PACKAGE_TARGET_DEP+= ${PKGOLDLATESTFILE} ${PKGOLDSIGFILE}
${PKGOLDLATESTFILE}: ${PKGOLDFILE} ${PKGLATESTREPOSITORY}
${INSTALL} -l rs ${PKGOLDFILE} ${PKGOLDLATESTFILE}
+
+# Temporary workaround to be deleted once every supported version of FreeBSD
+# have a bootstrap which handles the pkg extension.
+
+${PKGOLDSIGFILE}: ${PKGLATESTREPOSITORY}
+ ${INSTALL} -l rs pkg.pkg.sig ${PKGOLDSIGFILE}
.endif
. endif