aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-04-08 09:33:03 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-04-20 06:57:35 +0000
commitff2796d5bc837b0c6cb26791439c64f96fe1c090 (patch)
treef89bd3158d5c3c1fe64b605a6b717c4b60144823 /Mk
parenta91d65363fe8aa72bdf427bb639b0fe258ee7c01 (diff)
downloadports-ff2796d5bc837b0c6cb26791439c64f96fe1c090.tar.gz
ports-ff2796d5bc837b0c6cb26791439c64f96fe1c090.zip
Mk/Uses/meson.mk: Do not force color output (D29353)
By default Meson forces color output. Ninja strips the escape sequences before they go into the log. Samurai does not do that, so we end up with some garbage in the logs. Pass -Db_colorout=never to Meson to disable colors in general. Also see https://mesonbuild.com/Builtin-options.html This requires a small backport in devel/meson since the b_colorout option is broken with Clang at the moment. PR: 254678 Exp-run by: antoine
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/meson.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/Mk/Uses/meson.mk b/Mk/Uses/meson.mk
index 0322cb1ed47d..c089b76a0640 100644
--- a/Mk/Uses/meson.mk
+++ b/Mk/Uses/meson.mk
@@ -36,6 +36,11 @@ CONFIGURE_ARGS+= --prefix ${PREFIX} \
--mandir man \
--infodir ${INFO_PATH}
+# Disable color output. Meson forces it on by default, Ninja
+# strips it before it goes to the log, but Samurai does not, so we
+# might end up with ANSI escape sequences in the logs.
+CONFIGURE_ARGS+= -Db_colorout=never
+
# meson has it own strip mechanic
INSTALL_TARGET= install