aboutsummaryrefslogtreecommitdiff
path: root/Tools/make_readmes
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-11-19 13:45:07 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-11-19 13:45:07 +0000
commitae1ec8f3dc1e8236595aeed5f87444fdebbc245a (patch)
treebb7626e4fe5f767b810f8f05d7e9eb4a0ec261a5 /Tools/make_readmes
parentd8f7447a122c70937d781fea20d4ac3ec13e6283 (diff)
downloadports-ae1ec8f3dc1e8236595aeed5f87444fdebbc245a.tar.gz
ports-ae1ec8f3dc1e8236595aeed5f87444fdebbc245a.zip
* Fix INDEX build if MAINTAINER is not defined. [1]
* Remove USE_QT2 since it's obsolete now. [2] * Clarify comments about ARCH. [3] * Speedup 'make readmes'. Add a perl script "Tools/make_readmes" and modify bsd.port.subdir.mk to avoid recursing into individual port directories to create README.html. [4] * Fix 'make search' to allow case insensitive search on 5-x/6-x. [5] * Add the possibility to search the ports by category. [6] * Remove tk42 and tcl76 from virtual categories since they're obsolete. [7] * Introduce new variable - DISTVERSION, vendor version of the distribution, that can be set instead of PORTVERSION and is automatically converted in a conforming PORTVERSION. [8] * Use --suffix instead of -b option for patch(1) to make it compatible with BSD patch(1) [9] * Fix {WANT,WITH}_MYSQL_VER behavior, to deal with conflicting versions. [10] PR: ports/68895 [1], ports/69486 [2], ports/68539 [3], ports/70018 [4], ports/68896 [5], ports/73299 [6], ports/73570 [7], ports/67171 [8], ports/72182 [9] Submitted by: linimon [1][3], arved [2][7], cperciva [4], Matthew Seaman <m.seaman@infracaninophile.co.uk> [5], Radek Kozlowski <radek@raadradd.com> [6], eik [8], Andreas Hauser <andy-freebsd@splashground.de> [9], clement [10]
Notes
Notes: svn path=/head/; revision=121961
Diffstat (limited to 'Tools/make_readmes')
-rw-r--r--Tools/make_readmes47
1 files changed, 47 insertions, 0 deletions
diff --git a/Tools/make_readmes b/Tools/make_readmes
new file mode 100644
index 000000000000..186c7382c955
--- /dev/null
+++ b/Tools/make_readmes
@@ -0,0 +1,47 @@
+#!/usr/bin/perl
+
+$README=`cat Templates/README.port`;
+
+while(<>) {
+ split '\|';
+
+ $PKG=$_[0];
+ $PORT=$_[1];
+ $COMMENT=$_[3];
+ $DESCR=$_[4];
+ $EMAIL=$_[5];
+ $BUILD_DEPENDS=$_[7];
+ $RUN_DEPENDS=$_[8];
+ $WEBSITE=$_[9];
+
+ $DESCR=~s|^\Q$PORT/\E||;
+ $PORT=~s|`pwd`||;
+
+ if($WEBSITE) {
+ $WEBSITE=" and/or visit the <a href=\"$WEBSITE\">web site</a> for futher informations"
+ };
+ if($BUILD_DEPENDS) {
+ $BUILD_DEPENDS="This port requires package(s) \"$BUILD_DEPENDS\" to build."
+ };
+ if($RUN_DEPENDS) {
+ $RUN_DEPENDS="This port requires package(s) \"$RUN_DEPENDS\" to run."
+ };
+
+ $TOP=$PORT;
+ $TOP=~s|[^/]+|..|g;
+
+ $tmp=$README;
+ $tmp=~s|%%PKG%%|$PKG|g;
+ $tmp=~s|%%PORT%%|$PORT|g;
+ $tmp=~s|%%COMMENT%%|$COMMENT|g;
+ $tmp=~s|%%DESCR%%|$DESCR|g;
+ $tmp=~s|%%EMAIL%%|$EMAIL|g;
+ $tmp=~s|%%WEBSITE%%|$WEBSITE|g;
+ $tmp=~s|%%BUILD_DEPENDS%%|$BUILD_DEPENDS|g;
+ $tmp=~s|%%RUN_DEPENDS%%|$RUN_DEPENDS|g;
+ $tmp=~s|%%TOP%%|$TOP|g;
+
+ open F,">$PORT/README.html";
+ print F $tmp;
+ close F
+}