aboutsummaryrefslogtreecommitdiff
path: root/accessibility/caribou
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2018-09-30 11:58:29 +0000
committerKoop Mast <kwm@FreeBSD.org>2018-09-30 11:58:29 +0000
commit951c1f5d1c7354f058f5919d858dbb0c174dc73e (patch)
tree6146e775343aaf339921799078894a48fef9aa15 /accessibility/caribou
parentc9b47f0427d70ba42c2d53271f8b64b8e8096825 (diff)
downloadports-951c1f5d1c7354f058f5919d858dbb0c174dc73e.tar.gz
ports-951c1f5d1c7354f058f5919d858dbb0c174dc73e.zip
The FreeBSD GNOME team proudly presents GNOME 3.28 for FreeBSD.
The offical GNOME 3.28 release notes can be found at https://help.gnome.org/misc/release-notes/3.28/ Thanks to Antoine Brodin for running the exp-runs. PR: 229761
Notes
Notes: svn path=/head/; revision=480951
Diffstat (limited to 'accessibility/caribou')
-rw-r--r--accessibility/caribou/Makefile22
1 files changed, 13 insertions, 9 deletions
diff --git a/accessibility/caribou/Makefile b/accessibility/caribou/Makefile
index 25a5ed853687..df8fab27bd1c 100644
--- a/accessibility/caribou/Makefile
+++ b/accessibility/caribou/Makefile
@@ -3,7 +3,7 @@
PORTNAME= caribou
PORTVERSION= 0.4.21
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= accessibility gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -16,18 +16,22 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libclutter-glx-1.0.so:graphics/clutter \
libgee-0.8.so:devel/libgee \
- libxklavier.so:x11/libxklavier
-RUN_DEPENDS= py2?-atspi>=2.1.91:accessibility/py-atspi@${PY_FLAVOR}
+ libxklavier.so:x11/libxklavier \
+ libcogl-path.so:graphics/cogl \
+ libjson-glib-1.0.so:devel/json-glib \
+ libatspi.so:accessibility/at-spi2-core \
+ libdbus-1.so:devel/dbus
+RUN_DEPENDS= py3?-atspi>=2.1.91:accessibility/py-atspi@${PY_FLAVOR}
-USES= gettext gmake gnome libtool pathfix pkgconfig python:2.7 \
- shebangfix tar:xz
-USE_GNOME= gtk30 intlhack introspection:build libxml2 \
+USES= gettext gmake gnome libtool localbase pathfix \
+ pkgconfig python:3.3+ shebangfix tar:xz
+USE_GNOME= cairo gdkpixbuf2 gtk30 intlhack introspection:build libxml2 \
libxslt:build pygobject3
+USE_PYTHON= py3kplist
SHEBANG_FILES= tools/fix_gir.py tools/make_schema.py
-USE_XORG= x11 xtst
+USE_GL= egl
+USE_XORG= x11 xcomposite xdamage xext xfixes xi xrandr xtst
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
CONFIGURE_ARGS= --enable-gtk2-module=no