aboutsummaryrefslogtreecommitdiff
path: root/accessibility/gail/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-02-17 10:27:29 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-02-17 10:27:29 +0000
commit756cba40d52f9312d368d470fdd4c806a1770d8a (patch)
tree8f106f0b1b4260c7a163ab284806ebd5e6043da5 /accessibility/gail/Makefile
parentbf8da69411ce5dca2ae9b442a25963ac076274cd (diff)
downloadports-756cba40d52f9312d368d470fdd4c806a1770d8a.tar.gz
ports-756cba40d52f9312d368d470fdd4c806a1770d8a.zip
Notes
Diffstat (limited to 'accessibility/gail/Makefile')
-rw-r--r--accessibility/gail/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/accessibility/gail/Makefile b/accessibility/gail/Makefile
new file mode 100644
index 000000000000..46dfcfa88e66
--- /dev/null
+++ b/accessibility/gail/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: gail
+# Date Created: 12 February 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gail
+PORTVERSION= 0.6
+CATEGORIES= x11-toolkits
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-alpha2
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+LIB_DEPENDS= gnomecanvas-2.0:${PORTSDIR}/graphics/libgnomecanvas
+RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+pre-patch:
+ @find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
+ 's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
+
+.include <bsd.port.mk>