aboutsummaryrefslogtreecommitdiff
path: root/accessibility/gok/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2003-04-15 02:23:37 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2003-04-15 02:23:37 +0000
commitc6b1eba40f00db178caa57c2bfa45b2519f83f36 (patch)
tree0d0282b3b1134ad8470cdb52524d24d1bfcbdeae /accessibility/gok/Makefile
parent043f1e3f6a97edf92574ef21dac8ff41d9801a31 (diff)
downloadports-c6b1eba40f00db178caa57c2bfa45b2519f83f36.tar.gz
ports-c6b1eba40f00db178caa57c2bfa45b2519f83f36.zip
Notes
Diffstat (limited to 'accessibility/gok/Makefile')
-rw-r--r--accessibility/gok/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/accessibility/gok/Makefile b/accessibility/gok/Makefile
new file mode 100644
index 000000000000..50dfaf2d7425
--- /dev/null
+++ b/accessibility/gok/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gok
+# Date created: 12 April 2003
+# Whom: Adam Weinberger <adamw@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gok
+PORTVERSION= 0.7.0
+CATEGORIES= sysutils gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.7
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME On-Screen Keyboard (GOK)
+
+USE_X_PREFIX= yes
+USE_GNOME= gnomehack gnomeprefix libgnomeui atspi libwnck atk
+USE_REINPLACE= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|' \
+ ${WRKSRC}/gok/word-complete.c
+
+.include <bsd.port.mk>