aboutsummaryrefslogtreecommitdiff
path: root/accessibility/kmouth/Makefile
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-10-17 00:03:42 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-10-17 00:03:42 +0000
commita2d3b5a4bc5047210b788a128596ec34749ffa11 (patch)
treec3c20b47c3435ddcaf02b8570db6aab5b70011af /accessibility/kmouth/Makefile
parentda6ade2349d0bdc372133d4d97bc6988aee94238 (diff)
downloadports-a2d3b5a4bc5047210b788a128596ec34749ffa11.tar.gz
ports-a2d3b5a4bc5047210b788a128596ec34749ffa11.zip
Notes
Diffstat (limited to 'accessibility/kmouth/Makefile')
-rw-r--r--accessibility/kmouth/Makefile17
1 files changed, 6 insertions, 11 deletions
diff --git a/accessibility/kmouth/Makefile b/accessibility/kmouth/Makefile
index 0200ebde6ff1..aba07a53127c 100644
--- a/accessibility/kmouth/Makefile
+++ b/accessibility/kmouth/Makefile
@@ -22,26 +22,21 @@ USE_BZIP2= yes
USE_KDE4= kdelibs kdeprefix kdehier automoc4
KDE4_BUILDENV= yes
USE_QT_VER= 4
-QT_COMPONENTS= opengl gui qmake_build moc_build rcc_build uic_build
-USE_XORG= xtst
+QT_COMPONENTS= dbus gui qmake_build moc_build rcc_build uic_build
+USE_XORG= x11 xext xtst
MAKE_JOBS_SAFE= yes
+CMAKE_ARGS+= -DBUILD_jovie=OFF
MAN1= kmag.1 \
kmousetool.1 \
kmouth.1
-CMAKE_ARGS+= -DBUILD_jovie=OFF
-
-OPTIONS= KTTS "Enable KTTS speech service" off
+OPTIONS= JOVIE "Install Jovie text-to-speech system" on
.include <bsd.port.options.mk>
-.if defined(WITH_KTTS)
-RUN_DEPENDS+= ${KDE4_PREFIX}/bin/jovie:${PORTSDIR}/accessibility/ktts
+.ifndef(WITHOUT_JOVIE)
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/jovie:${PORTSDIR}/accessibility/jovie
.endif
-post-patch:
- ${REINPLACE_CMD} -e 's/speechd/$$$\{SPEECHD_LIBRARY}/g' \
- ${PATCH_WRKSRC}/kaccessible/CMakeLists.txt
-
.include <bsd.port.mk>