aboutsummaryrefslogtreecommitdiff
path: root/accessibility/qt5-speech
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2018-01-06 21:30:31 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2018-01-06 21:30:31 +0000
commitf6ceca63504679b05ea4fc24a195a301e2303d1f (patch)
treea6e116c43545a3682fe63db4bdca54e6fb24567e /accessibility/qt5-speech
parent78a4d3df994a008dd752fd82307fd6d31aa18f3a (diff)
downloadports-f6ceca63504679b05ea4fc24a195a301e2303d1f.tar.gz
ports-f6ceca63504679b05ea4fc24a195a301e2303d1f.zip
Update Qt5 ports to 5.9.3.
This took quite a lot of time because Qt's own build system underwent several changes in 5.8.0 that took a while to adapt to. And, of course, qt5-webengine is a behemoth that we need to patch like crazy due to its bundling of Chromium. In fact, most of the Chromium patches in qt5-webengine have been imported with no changes from www/chromium@433510 ("www/chromium: update to 56.0.2924.87"). New port: accessibility/qt5-speech Bigger changes to Qt5 ports we had to make: - Qt now allows using a configure.json file to define configuration options and specify configuration checks that can be done when qmake is invoked. However, configure.json checks done in a subdirectory only propagates to subdirectories, and checks elsewhere will fail if all .pro files are being parsed at once (i.e. qmake -recursive), so several ports had to switch to USES=qmake:norecursive along with manual additional qmake invocations in subdirectories in order to work. It's been mentioned in a few places such as Qt's bug tracker that qmake's recursive mode is pretty much deprecated, so we might switch to non-recursive mode by default in the future. - Uses/qmake.mk: Introduce QMAKE_CONFIGURE_ARGS. qmake now accepts arbitrary options such as '-foo' and '-no-bar' at the end of the command-line. They can be specified in QMAKE_CONFIGURE_ARGS. - graphics/qt5-wayland: The port can only be built if graphics/mesa-libs is built with the WAYLAND option, so a corresponding option (off by default) was added to the port. - misc/qt5-doc: Switch to a pre-built documentation tarball. The existing port was not working with Qt 5.9. Instead of trying to fix it, switch to what Gentoo does and fetch a tarball that already contains all documentation so that we do not have to build anything at all. The tarball's name and location in download.qt.io look a bit weird, but it seems to work fine. - www/qt5-webengine: Use binutils from ports, Chromium's GN build system generates a build.ninja that uses ar(1) with the @file syntax that is not supported by BSD ar, so we need to use GNU ar from binutils. - x11-toolkits/qt5-declarative-render2d: This port was merged into the main Qt Declarative repository upstream, and into x11-toolkits/qt5-quick in the ports tree. Changes to other ports we had to make: - biology/ugene: Drop a '#define point "."' that is not present in more recent versions of the port. Defining a macro with such a common name causes build issues with Qt 5.9, which uses |point| as an argument name in methods. - cad/qelectrotech: Fix plist with Qt 5.9. Directories are no longer installed with `cp -f -R', but rather `qmake install qinstall', which does not install %%DATADIR%%/elements/10_electric/20_manufacturers_articles/bosch_rexroth/.directory That's a local file that should not even have been part of the tarball anyway. - chinese/gcin-qt5: Add additional private Qt directories (which should not be used in the first place) to get the port to build with Qt 5.9. - devel/qtcreator: Fix plist with Qt 5.9. Something changed in qdoc and some test classes no longer generate documentation files. - security/keepassx-devel: Import a patch sent upstream almost a year ago to fix the build with Qt 5.9. Thanks to antoine for the exp-run, and tcberner and Laurent Cimon <laurent@nuxi.ca> for landing changes in our qt-5.9 branch. PR: 224849
Notes
Notes: svn path=/head/; revision=458293
Diffstat (limited to 'accessibility/qt5-speech')
-rw-r--r--accessibility/qt5-speech/Makefile17
-rw-r--r--accessibility/qt5-speech/pkg-plist28
2 files changed, 45 insertions, 0 deletions
diff --git a/accessibility/qt5-speech/Makefile b/accessibility/qt5-speech/Makefile
new file mode 100644
index 000000000000..a3c1f30444c3
--- /dev/null
+++ b/accessibility/qt5-speech/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= speech
+DISTVERSION= ${QT5_VERSION}
+CATEGORIES= accessibility
+PKGNAMEPREFIX= qt5-
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Accessibilty features for Qt5
+
+LIB_DEPENDS= libspeechd.so:accessibility/speech-dispatcher
+
+USES= pkgconfig qmake:outsource
+USE_QT5= core gui buildtools_build qmake_build
+QT_DIST= ${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/accessibility/qt5-speech/pkg-plist b/accessibility/qt5-speech/pkg-plist
new file mode 100644
index 000000000000..3a024949d0f6
--- /dev/null
+++ b/accessibility/qt5-speech/pkg-plist
@@ -0,0 +1,28 @@
+%%QT_INCDIR%%/QtTextToSpeech/%%FULLVER%%/QtTextToSpeech/private/qtexttospeech_p.h
+%%QT_INCDIR%%/QtTextToSpeech/%%FULLVER%%/QtTextToSpeech/private/qvoice_p.h
+%%QT_INCDIR%%/QtTextToSpeech/QTextToSpeech
+%%QT_INCDIR%%/QtTextToSpeech/QTextToSpeechEngine
+%%QT_INCDIR%%/QtTextToSpeech/QTextToSpeechPlugin
+%%QT_INCDIR%%/QtTextToSpeech/QVoice
+%%QT_INCDIR%%/QtTextToSpeech/QtTextToSpeech
+%%QT_INCDIR%%/QtTextToSpeech/QtTextToSpeechDepends
+%%QT_INCDIR%%/QtTextToSpeech/QtTextToSpeechVersion
+%%QT_INCDIR%%/QtTextToSpeech/qtexttospeech.h
+%%QT_INCDIR%%/QtTextToSpeech/qtexttospeech_global.h
+%%QT_INCDIR%%/QtTextToSpeech/qtexttospeechengine.h
+%%QT_INCDIR%%/QtTextToSpeech/qtexttospeechplugin.h
+%%QT_INCDIR%%/QtTextToSpeech/qttexttospeechversion.h
+%%QT_INCDIR%%/QtTextToSpeech/qvoice.h
+%%QT_CMAKEDIR%%/Qt5TextToSpeech/Qt5TextToSpeechConfig.cmake
+%%QT_CMAKEDIR%%/Qt5TextToSpeech/Qt5TextToSpeechConfigVersion.cmake
+%%QT_CMAKEDIR%%/Qt5TextToSpeech/Qt5TextToSpeech_QTextToSpeechPluginSpeechd.cmake
+%%QT_LIBDIR%%/libQt5TextToSpeech.prl
+%%QT_LIBDIR%%/libQt5TextToSpeech.so
+%%QT_LIBDIR%%/libQt5TextToSpeech.so.5
+%%QT_LIBDIR%%/libQt5TextToSpeech.so.%%SHORTVER%%
+%%QT_LIBDIR%%/libQt5TextToSpeech.so.%%FULLVER%%
+%%DEBUG%%%%QT_LIBDIR%%/libQt5TextToSpeech.so.%%FULLVER%%.debug
+%%QT_MKSPECDIR%%/modules/qt_lib_texttospeech.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_texttospeech_private.pri
+%%QT_PLUGINDIR%%/texttospeech/libqtexttospeech_speechd.so
+libdata/pkgconfig/Qt5TextToSpeech.pc