aboutsummaryrefslogtreecommitdiff
path: root/accessibility/speech-dispatcher
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2015-06-29 15:51:22 +0000
committerAlberto Villa <avilla@FreeBSD.org>2015-06-29 15:51:22 +0000
commit54eec56d106cc4f53fd89f68ddf81c328c70dc04 (patch)
tree83dcaf5a5535c3ac0c84cd48c965752d78982161 /accessibility/speech-dispatcher
parent26f58ed1c0cab0bd529c1b8e75d4fee11a8d80f7 (diff)
downloadports-54eec56d106cc4f53fd89f68ddf81c328c70dc04.tar.gz
ports-54eec56d106cc4f53fd89f68ddf81c328c70dc04.zip
accessibility/speech-dispatcher: update to 0.8.3
- Enable optional Python bindings (Python 3 required) - Make NLS optional - Remove original .conf files from DATADIR (.sample files available) - Remove stale patches
Notes
Notes: svn path=/head/; revision=390919
Diffstat (limited to 'accessibility/speech-dispatcher')
-rw-r--r--accessibility/speech-dispatcher/Makefile41
-rw-r--r--accessibility/speech-dispatcher/distinfo4
-rw-r--r--accessibility/speech-dispatcher/files/patch-include__spd_utils.h11
-rw-r--r--accessibility/speech-dispatcher/files/patch-src__common__spd_getline.c34
-rw-r--r--accessibility/speech-dispatcher/files/patch-src__modules__cicero.c21
-rw-r--r--accessibility/speech-dispatcher/files/patch-src__server__output.c25
-rw-r--r--accessibility/speech-dispatcher/files/patch-src__server__sem_functions.c18
-rw-r--r--accessibility/speech-dispatcher/files/patch-src__server__speaking.c22
-rw-r--r--accessibility/speech-dispatcher/files/patch-src__server__speechd.h8
-rw-r--r--accessibility/speech-dispatcher/pkg-plist25
10 files changed, 39 insertions, 170 deletions
diff --git a/accessibility/speech-dispatcher/Makefile b/accessibility/speech-dispatcher/Makefile
index 3ebab20eeb21..8291bc928eeb 100644
--- a/accessibility/speech-dispatcher/Makefile
+++ b/accessibility/speech-dispatcher/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= speech-dispatcher
-PORTVERSION= 0.8
-PORTREVISION= 2
+PORTVERSION= 0.8.3
CATEGORIES= accessibility audio
MASTER_SITES= http://devel.freebsoft.org/pub/projects/speechd/
@@ -17,14 +16,14 @@ LIB_DEPENDS= libdotconf.so:${PORTSDIR}/devel/dotconf \
libsndfile.so:${PORTSDIR}/audio/libsndfile
USE_GNOME= glib20 intltool
-USES= alias gettext gmake pathfix pkgconfig libtool
+USES= alias gmake pathfix pkgconfig libtool
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
-ETCFILES= clients/emacs.conf clients/gnome-speech.conf \
+ETCFILES= clients/emacs.conf modules/pico-generic.conf \
modules/cicero.conf modules/dtk-generic.conf \
modules/epos-generic.conf modules/espeak-generic.conf \
modules/espeak-mbrola-generic.conf modules/espeak.conf \
@@ -32,13 +31,12 @@ ETCFILES= clients/emacs.conf clients/gnome-speech.conf \
modules/ivona.conf modules/llia_phon-generic.conf \
modules/swift-generic.conf speechd.conf
-PLIST_SUB+= ETCFILES="${ETCFILES}"
-
-PORTDOCS= AUTHORS ChangeLog FAQ INSTALL NEWS README TODO
+PORTDOCS= ANNOUNCE AUTHORS ChangeLog FAQ NEWS README TODO
INFO= spd-say speech-dispatcher ssip
-OPTIONS_DEFINE= ALSA AO DOCS ESPEAK FESTIVAL FLITE NAS PULSEAUDIO #PYTHON
+OPTIONS_DEFINE= ALSA AO DOCS ESPEAK FESTIVAL FLITE NAS NLS \
+ PULSEAUDIO PYTHON
OPTIONS_DEFAULT=ESPEAK
OPTIONS_SUB= yes
@@ -63,25 +61,40 @@ FLITE_CONFIGURE_WITH= flite
NAS_LIB_DEPENDS= libaudio.so:${PORTSDIR}/audio/nas
NAS_CONFIGURE_WITH= nas
+NLS_USES= gettext
+
PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
PULSEAUDIO_CONFIGURE_WITH=pulse
-# devel/py-xdg doesn't support Python 3.
-CONFIGURE_ARGS+= --disable-python
-PLIST_SUB+= PYTHON="@comment "
-#PYTHON_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg
-#PYTHON_USE= PYTHON=3
-#PYTHON_CONFIGURE_ENABLE=python
+PYTHON_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py3-xdg
+PYTHON_USES= python:3
+PYTHON_USE= PYTHON=py3kplist
+PYTHON_CONFIGURE_ENABLE=python
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+INFO+= speech-dispatcher-cs
+.endif
post-patch:
@${REINPLACE_CMD} -e '/SUBDIRS/ s/tests//' \
${WRKSRC}/src/Makefile.in
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -e '/SUBDIRS/ s/po//' \
+ ${WRKSRC}/Makefile.in
+.endif
post-install:
.for f in ${ETCFILES}
@${MV} ${STAGEDIR}${ETCDIR}/${f} ${STAGEDIR}${ETCDIR}/${f}.sample
.endfor
+ @${RM} -rf ${STAGEDIR}${DATADIR}/conf
+ @${RMDIR} ${STAGEDIR}${DATADIR} || ${TRUE}
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+.if ! ${PORT_OPTIONS:MNLS}
+ @${RM} -f ${STAGEDIR}${PREFIX}/${INFO_PATH}/speech-dispatcher-cs.info
+.endif
.include <bsd.port.mk>
diff --git a/accessibility/speech-dispatcher/distinfo b/accessibility/speech-dispatcher/distinfo
index 7811e65911af..1d6d45922977 100644
--- a/accessibility/speech-dispatcher/distinfo
+++ b/accessibility/speech-dispatcher/distinfo
@@ -1,2 +1,2 @@
-SHA256 (speech-dispatcher-0.8.tar.gz) = 0a6ce544cfbac8592a8ea08e3ab24c389153904ea51c6fd68756cea52de9efa2
-SIZE (speech-dispatcher-0.8.tar.gz) = 1229312
+SHA256 (speech-dispatcher-0.8.3.tar.gz) = 96a293b2ba1e2498f1280c75a9607891a9990947a8d87e9855c2a642c93f1e4f
+SIZE (speech-dispatcher-0.8.3.tar.gz) = 1292321
diff --git a/accessibility/speech-dispatcher/files/patch-include__spd_utils.h b/accessibility/speech-dispatcher/files/patch-include__spd_utils.h
deleted file mode 100644
index 2b319e8e8968..000000000000
--- a/accessibility/speech-dispatcher/files/patch-include__spd_utils.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./include/spd_utils.h.orig 2012-07-11 11:05:05.000000000 +0200
-+++ ./include/spd_utils.h 2013-11-15 08:46:53.865350816 +0100
-@@ -27,4 +27,8 @@
- #include <sys/types.h>
-
- ssize_t spd_getline(char **lineptr, size_t * n, FILE * f);
-+
-+ssize_t safe_read(int fd, void *buf, size_t count);
-+ssize_t safe_write(int fd, const void *buf, size_t count);
-+
- #endif /* SPD_UTILS_H */
diff --git a/accessibility/speech-dispatcher/files/patch-src__common__spd_getline.c b/accessibility/speech-dispatcher/files/patch-src__common__spd_getline.c
deleted file mode 100644
index 1431018c5e20..000000000000
--- a/accessibility/speech-dispatcher/files/patch-src__common__spd_getline.c
+++ /dev/null
@@ -1,34 +0,0 @@
---- ./src/common/spd_getline.c.orig 2012-07-11 11:05:05.000000000 +0200
-+++ ./src/common/spd_getline.c 2013-11-15 11:25:07.125139008 +0100
-@@ -26,6 +26,7 @@
-
- #include <stdio.h>
- #include <stdlib.h>
-+#include <unistd.h>
- #include <errno.h>
- #include <limits.h>
- #include <glib.h>
-@@ -122,3 +123,23 @@
- }
- return buf_pos;
- }
-+
-+ssize_t
-+safe_read(int fd, void *buf, size_t count)
-+{
-+ ssize_t r;
-+ do {
-+ r = read(fd, buf, count);
-+ } while (r == -1 && errno == EINTR);
-+ return r;
-+}
-+
-+ssize_t
-+safe_write(int fd, const void *buf, size_t count)
-+{
-+ ssize_t w;
-+ do {
-+ w = write(fd, buf, count);
-+ } while (w == -1 && errno == EINTR);
-+ return w;
-+}
diff --git a/accessibility/speech-dispatcher/files/patch-src__modules__cicero.c b/accessibility/speech-dispatcher/files/patch-src__modules__cicero.c
deleted file mode 100644
index 5a0edafa1edf..000000000000
--- a/accessibility/speech-dispatcher/files/patch-src__modules__cicero.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- ./src/modules/cicero.c.orig 2012-07-11 11:05:05.000000000 +0200
-+++ ./src/modules/cicero.c 2013-11-15 08:51:41.687674164 +0100
-@@ -32,6 +32,7 @@
- #include <langinfo.h>
- #include <sys/stat.h>
- #include <semaphore.h>
-+#include <spd_utils.h>
-
- #include "module_utils.h"
-
-@@ -377,9 +378,7 @@
- break;
- }
- if (ret > 0)
-- TEMP_FAILURE_RETRY(read
-- (fd1[0], b,
-- 2));
-+ safe_read(fd1[0], b, 2);
- if (cicero_stop) {
- cicero_speaking = 0;
- module_report_event_stop();
diff --git a/accessibility/speech-dispatcher/files/patch-src__server__output.c b/accessibility/speech-dispatcher/files/patch-src__server__output.c
deleted file mode 100644
index e51f373b3812..000000000000
--- a/accessibility/speech-dispatcher/files/patch-src__server__output.c
+++ /dev/null
@@ -1,25 +0,0 @@
---- ./src/server/output.c.orig 2012-07-11 11:05:06.000000000 +0200
-+++ ./src/server/output.c 2013-11-15 11:18:27.066817985 +0100
-@@ -30,22 +30,9 @@
- #include "output.h"
- #include "parse.h"
-
--#ifdef TEMP_FAILURE_RETRY /* GNU libc */
--#define safe_write(fd, buf, count) TEMP_FAILURE_RETRY(write(fd, buf, count))
--#else /* TEMP_FAILURE_RETRY */
- #ifdef HAVE_UNISTD_H
- #include <unistd.h>
- #endif
--static inline ssize_t
--safe_write(int fd, const void *buf, size_t count) {
-- do {
-- ssize_t w = write(fd, buf, count);
--
-- if (w == -1 && errno == EINTR) continue;
-- return w;
-- } while (1);
--}
--#endif /* TEMP_FAILURE_RETRY */
-
- #if !(defined(__GLIBC__) && defined(_GNU_SOURCE))
- /* Added by Willie Walker - strndup is a gcc-ism
diff --git a/accessibility/speech-dispatcher/files/patch-src__server__sem_functions.c b/accessibility/speech-dispatcher/files/patch-src__server__sem_functions.c
deleted file mode 100644
index 2aee68e32166..000000000000
--- a/accessibility/speech-dispatcher/files/patch-src__server__sem_functions.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- ./src/server/sem_functions.c.orig 2012-07-11 11:05:06.000000000 +0200
-+++ ./src/server/sem_functions.c 2013-11-15 11:19:15.965146025 +0100
-@@ -28,13 +28,13 @@
-
- #include "speechd.h"
- #include "sem_functions.h"
-+#include <spd_utils.h>
-
- void speaking_semaphore_post(void)
- {
- char buf[1];
- buf[0] = 42;
-- const ssize_t wr_bytes =
-- TEMP_FAILURE_RETRY(write(speaking_pipe[1], buf, 1));
-+ const ssize_t wr_bytes = safe_write(speaking_pipe[1], buf, 1);
- if (wr_bytes != 1)
- FATAL("write to polled fd: could not write 1 byte");
- }
diff --git a/accessibility/speech-dispatcher/files/patch-src__server__speaking.c b/accessibility/speech-dispatcher/files/patch-src__server__speaking.c
deleted file mode 100644
index b0b457c38d34..000000000000
--- a/accessibility/speech-dispatcher/files/patch-src__server__speaking.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- ./src/server/speaking.c.orig 2012-07-11 11:05:06.000000000 +0200
-+++ ./src/server/speaking.c 2013-11-15 11:20:31.405951238 +0100
-@@ -39,6 +39,7 @@
- #include "output.h"
- #include "speaking.h"
- #include "sem_functions.h"
-+#include <spd_utils.h>
-
- TSpeechDMessage *current_message = NULL;
- static SPDPriority highest_priority = 0;
-@@ -87,10 +88,7 @@
- char buf[1];
- MSG(5,
- "wait_for_poll: activity in Speech Dispatcher");
-- const ssize_t rd_bytes =
-- TEMP_FAILURE_RETRY(read
-- (poll_fds[0].fd, buf,
-- 1));
-+ const ssize_t rd_bytes = safe_read(poll_fds[0].fd, buf, 1);
- if (rd_bytes != 1)
- FATAL
- ("read from polled fd: could not read 1 byte");
diff --git a/accessibility/speech-dispatcher/files/patch-src__server__speechd.h b/accessibility/speech-dispatcher/files/patch-src__server__speechd.h
index 7ae850c814ac..ae963e2f6e49 100644
--- a/accessibility/speech-dispatcher/files/patch-src__server__speechd.h
+++ b/accessibility/speech-dispatcher/files/patch-src__server__speechd.h
@@ -1,11 +1,11 @@
---- ./src/server/speechd.h.orig 2012-07-11 11:05:06.000000000 +0200
-+++ ./src/server/speechd.h 2013-11-15 08:44:05.115355454 +0100
+--- src/server/speechd.h.orig 2015-06-04 01:52:14 UTC
++++ src/server/speechd.h
@@ -56,7 +56,7 @@
/* TODO: This fixes compilation for Mac OS X but might not be a correct
solution for other platforms. A better check is needed, possibly including
_POSIX_C_SOURCE and friends*/
-#if (defined(__GNU_LIBRARY__) && !defined(_SEM_SEMUN_UNDEFINED)) || defined(__APPLE__)
+#if (defined(__GNU_LIBRARY__) && !defined(_SEM_SEMUN_UNDEFINED)) || defined(__APPLE__) || defined(__FreeBSD__)
- /* union semun is defined by including <sys/sem.h> */
+ /* union semun is defined by including <sys/sem.h> */
#else
- /* according to X/OPEN we have to define it ourselves */
+ /* according to X/OPEN we have to define it ourselves */
diff --git a/accessibility/speech-dispatcher/pkg-plist b/accessibility/speech-dispatcher/pkg-plist
index c91b12a54849..4e48c1c973df 100644
--- a/accessibility/speech-dispatcher/pkg-plist
+++ b/accessibility/speech-dispatcher/pkg-plist
@@ -3,7 +3,6 @@ bin/spd-say
bin/spdsend
bin/speech-dispatcher
@sample %%ETCDIR%%/clients/emacs.conf.sample
-@sample %%ETCDIR%%/clients/gnome-speech.conf.sample
@sample %%ETCDIR%%/modules/cicero.conf.sample
@sample %%ETCDIR%%/modules/dtk-generic.conf.sample
@sample %%ETCDIR%%/modules/epos-generic.conf.sample
@@ -15,15 +14,18 @@ bin/speech-dispatcher
@sample %%ETCDIR%%/modules/ibmtts.conf.sample
@sample %%ETCDIR%%/modules/ivona.conf.sample
@sample %%ETCDIR%%/modules/llia_phon-generic.conf.sample
+@sample %%ETCDIR%%/modules/pico-generic.conf.sample
@sample %%ETCDIR%%/modules/swift-generic.conf.sample
@sample %%ETCDIR%%/speechd.conf.sample
include/speech-dispatcher/libspeechd.h
+include/speech-dispatcher/libspeechd_version.h
include/speech-dispatcher/spd_audio_plugin.h
+include/speech-dispatcher/speechd_defines.h
include/speech-dispatcher/speechd_types.h
lib/libspeechd.a
lib/libspeechd.so
lib/libspeechd.so.2
-lib/libspeechd.so.2.4.0
+lib/libspeechd.so.2.6.0
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd/__init__.py
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd/__init__.pyc
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd/__init__.pyo
@@ -62,22 +64,7 @@ lib/speech-dispatcher/spd_oss.so
%%PULSEAUDIO%%lib/speech-dispatcher/spd_pulse.a
%%PULSEAUDIO%%lib/speech-dispatcher/spd_pulse.so
libdata/pkgconfig/speech-dispatcher.pc
-share/locale/cs/LC_MESSAGES/speech-dispatcher.mo
-share/locale/hu/LC_MESSAGES/speech-dispatcher.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/speech-dispatcher.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/speech-dispatcher.mo
share/sounds/speech-dispatcher/dummy-message.wav
%%PYTHON%%share/sounds/speech-dispatcher/test.wav
-%%DATADIR%%/conf/clients/emacs.conf
-%%DATADIR%%/conf/clients/gnome-speech.conf
-%%DATADIR%%/conf/modules/cicero.conf
-%%DATADIR%%/conf/modules/dtk-generic.conf
-%%DATADIR%%/conf/modules/epos-generic.conf
-%%DATADIR%%/conf/modules/espeak-generic.conf
-%%DATADIR%%/conf/modules/espeak-mbrola-generic.conf
-%%DATADIR%%/conf/modules/espeak.conf
-%%DATADIR%%/conf/modules/festival.conf
-%%DATADIR%%/conf/modules/flite.conf
-%%DATADIR%%/conf/modules/ibmtts.conf
-%%DATADIR%%/conf/modules/ivona.conf
-%%DATADIR%%/conf/modules/llia_phon-generic.conf
-%%DATADIR%%/conf/modules/swift-generic.conf
-%%DATADIR%%/conf/speechd.conf