aboutsummaryrefslogtreecommitdiff
path: root/accessibility
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2020-06-11 17:47:16 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2020-06-11 17:47:16 +0000
commit033acbba3ca1ad4ebb5410cffebfaa24169c3da6 (patch)
treecb8b244b52983f6a9c3eb6394012f01e98b98ce6 /accessibility
parent65078408b7d8a04ac1e84bae77b8257835c82829 (diff)
downloadports-033acbba3ca1ad4ebb5410cffebfaa24169c3da6.tar.gz
ports-033acbba3ca1ad4ebb5410cffebfaa24169c3da6.zip
Update to 2.36.0
Notes
Notes: svn path=/head/; revision=538518
Diffstat (limited to 'accessibility')
-rw-r--r--accessibility/py-atspi/Makefile2
-rw-r--r--accessibility/py-atspi/distinfo6
-rw-r--r--accessibility/py-atspi/files/patch-pyatspi_registry.py69
3 files changed, 4 insertions, 73 deletions
diff --git a/accessibility/py-atspi/Makefile b/accessibility/py-atspi/Makefile
index b0456003dcc1..4c22a8bce132 100644
--- a/accessibility/py-atspi/Makefile
+++ b/accessibility/py-atspi/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= atspi
-PORTVERSION= 2.26.0
+PORTVERSION= 2.36.0
CATEGORIES= accessibility x11-toolkits python
MASTER_SITES= GNOME/sources/pyatspi/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/accessibility/py-atspi/distinfo b/accessibility/py-atspi/distinfo
index 30b6acc758b9..1e61d02d09b3 100644
--- a/accessibility/py-atspi/distinfo
+++ b/accessibility/py-atspi/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1505474027
-SHA256 (gnome3/pyatspi-2.26.0.tar.xz) = c696e47cf3d757dc515a2005ce22c7b580655a233ae6e47b39eefdfe4e8fb675
-SIZE (gnome3/pyatspi-2.26.0.tar.xz) = 309780
+TIMESTAMP = 1591897575
+SHA256 (gnome3/pyatspi-2.36.0.tar.xz) = 5136c1bf919e101d4ec901a276e86ea60e5881a8ff7763e356f19840e5ffe1dd
+SIZE (gnome3/pyatspi-2.36.0.tar.xz) = 315076
diff --git a/accessibility/py-atspi/files/patch-pyatspi_registry.py b/accessibility/py-atspi/files/patch-pyatspi_registry.py
deleted file mode 100644
index b4cf966abc72..000000000000
--- a/accessibility/py-atspi/files/patch-pyatspi_registry.py
+++ /dev/null
@@ -1,69 +0,0 @@
-Upstream patch for https://gitlab.gnome.org/GNOME/pyatspi2/issues/1
-
-diff --git pyatspi/registry.py pyatspi/registry.py
-index cb28395..f73ee16 100644
---- pyatspi/registry.py
-+++ pyatspi/registry.py
-@@ -50,9 +50,9 @@ class Registry(object):
- reference to the Accessibility.Registry singleton. Doing so is harmless and
- has no point.
-
-- @@ivar async: Should event dispatch to local listeners be decoupled from event
-- receiving from the registry?
-- @@type async: boolean
-+ @@ivar asynchronous: Should event dispatch to local listeners be decoupled
-+ from event receiving from the registry?
-+ @@type asynchronous: boolean
- @@ivar reg: Reference to the real, wrapped registry object
- @@type reg: Accessibility.Registry
- @@ivar dev: Reference to the device controller
-@@ -111,25 +111,44 @@ def _set_registry (self, main_loop_type, app_name=None):
-
- self.has_implementations = True
-
-- self.async = False # not fully supported yet
-+ self.asynchronous = False # not fully supported yet
- self.started = False
- self.event_listeners = dict()
-
-+ def __getattr__(self, name):
-+ """
-+ For backwards compatibility with old API
-+ """
-+ if name == 'async':
-+ return self.asynchronous
-+ return object.__getattr__(self, name)
-+
-+ def __setattr__(self, name, value):
-+ """
-+ For backwards compatibility with old API
-+ """
-+ if name == 'async':
-+ self.asynchronous = value
-+ object.__setattr__(self, name, value)
-+
- def _set_default_registry (self):
- self._set_registry (MAIN_LOOP_GLIB)
-
-- def start(self, async=False, gil=True):
-+ def start(self, asynchronous=False, gil=True, **kwargs):
- """
- Enter the main loop to start receiving and dispatching events.
-
-- @@param async: Should event dispatch be asynchronous (decoupled) from
-- event receiving from the AT-SPI registry?
-- @@type async: boolean
-+ @@param asynchronous: Should event dispatch be asynchronous
-+ (decoupled) from event receiving from the AT-SPI registry?
-+ @@type asynchronous: boolean
- @@param gil: Add an idle callback which releases the Python GIL for a few
- milliseconds to allow other threads to run? Necessary if other threads
- will be used in this process.
- @@type gil: boolean
- """
-+ if 'async' in kwargs:
-+ # support previous API
-+ asynchronous = kwargs['async']
- if not self.has_implementations:
- self._set_default_registry ()
- self.started = True