aboutsummaryrefslogtreecommitdiff
path: root/accessibility
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-07-10 16:21:05 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-07-10 16:21:05 +0000
commit6b6cd0b3e4944d5fd99a4450ee70c5868404aeae (patch)
tree6f081e84a368685b54bf3c2ac3ecefae9ca7ff2e /accessibility
parent036a3a6b7855dcaaa36b3619d73ec73f1564d8cc (diff)
downloadports-6b6cd0b3e4944d5fd99a4450ee70c5868404aeae.tar.gz
ports-6b6cd0b3e4944d5fd99a4450ee70c5868404aeae.zip
accesibility/speech-dispatcher: Unbreak build with -fno-common
ld: error: duplicate symbol: GlobalFDSet >>> defined at speechd.c >>> speech_dispatcher-speechd.o:(GlobalFDSet) >>> defined at server.c >>> speech_dispatcher-server.o:(.bss+0x148) ld: error: duplicate symbol: MessagePausedList >>> defined at speechd.c >>> speech_dispatcher-speechd.o:(MessagePausedList) >>> defined at server.c >>> speech_dispatcher-server.o:(.bss+0x138) ld: error: duplicate symbol: MessageQueue >>> defined at speechd.c >>> speech_dispatcher-speechd.o:(MessageQueue) >>> defined at server.c >>> speech_dispatcher-server.o:(.bss+0x10) ld: error: duplicate symbol: SpeechdOptions >>> defined at speechd.c >>> speech_dispatcher-speechd.o:(SpeechdOptions) >>> defined at server.c >>> speech_dispatcher-server.o:(.bss+0x60) ld: error: duplicate symbol: SpeechdStatus >>> defined at speechd.c >>> speech_dispatcher-speechd.o:(SpeechdStatus) >>> defined at server.c >>> speech_dispatcher-server.o:(.bss+0xF8) ld: error: duplicate symbol: client_specific_settings >>> defined at speechd.c >>> speech_dispatcher-speechd.o:(client_specific_settings) >>> defined at server.c >>> speech_dispatcher-server.o:(.bss+0x140) ld: error: duplicate symbol: custom_log_kind >>> defined at speechd.c >>> speech_dispatcher-speechd.o:(custom_log_kind) >>> defined at server.c >>> speech_dispatcher-server.o:(.bss+0x230) ld: error: duplicate symbol: custom_logfile >>> defined at speechd.c >>> speech_dispatcher-speechd.o:(custom_logfile) >>> defined at server.c >>> speech_dispatcher-server.o:(.bss+0x228) ld: error: duplicate symbol: debug_logfile >>> defined at speechd.c >>> speech_dispatcher-speechd.o:(debug_logfile) >>> defined at server.c >>> speech_dispatcher-server.o:(.bss+0x238) ld: error: duplicate symbol: element_free_mutex >>> defined at speechd.c >>> speech_dispatcher-speechd.o:(element_free_mutex) >>> defined at server.c >>> speech_dispatcher-server.o:(.bss+0x8) ld: error: duplicate symbol: fd_settings >>> defined at speechd.c >>> speech_dispatcher-speechd.o:(fd_settings) >>> defined at server.c >>> speech_dispatcher-server.o:(.bss+0x120) ld: error: duplicate symbol: fd_uid >>> defined at speechd.c >>> speech_dispatcher-speechd.o:(fd_uid) >>> defined at server.c >>> speech_dispatcher-server.o:(.bss+0x130) ld: error: duplicate symbol: language_default_modules >>> defined at speechd.c >>> speech_dispatcher-speechd.o:(language_default_modules) >>> defined at server.c >>> speech_dispatcher-server.o:(.bss+0x128) ld: error: duplicate symbol: last_p5_block >>> defined at speechd.c >>> speech_dispatcher-speechd.o:(last_p5_block) >>> defined at server.c >>> speech_dispatcher-server.o:(.bss+0x18) ld: error: duplicate symbol: logfile >>> defined at speechd.c >>> speech_dispatcher-speechd.o:(logfile) >>> defined at server.c >>> speech_dispatcher-server.o:(.bss+0x220) ld: error: duplicate symbol: logging_mutex >>> defined at speechd.c >>> speech_dispatcher-speechd.o:(logging_mutex) >>> defined at server.c >>> speech_dispatcher-server.o:(.bss+0x110) ld: error: duplicate symbol: output_layer_mutex >>> defined at speechd.c >>> speech_dispatcher-speechd.o:(output_layer_mutex) >>> defined at server.c >>> speech_dispatcher-server.o:(.bss+0x118) ld: error: duplicate symbol: p_msg_lc >>> defined at speechd.c >>> speech_dispatcher-speechd.o:(p_msg_lc) >>> defined at server.c >>> speech_dispatcher-server.o:(.bss+0x28) ld: error: duplicate symbol: p_msg_uid_lc >>> defined at speechd.c >>> speech_dispatcher-speechd.o:(p_msg_uid_lc) >>> defined at server.c >>> speech_dispatcher-server.o:(.bss+0x30) ld: error: duplicate symbol: pause_requested >>> defined at speechd.c >>> speech_dispatcher-speechd.o:(pause_requested) >>> defined at server.c >>> speech_dispatcher-server.o:(.bss+0x50)
Notes
Notes: svn path=/head/; revision=541866
Diffstat (limited to 'accessibility')
-rw-r--r--accessibility/speech-dispatcher/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/accessibility/speech-dispatcher/Makefile b/accessibility/speech-dispatcher/Makefile
index 3f60c036c50b..6f3a31606a9c 100644
--- a/accessibility/speech-dispatcher/Makefile
+++ b/accessibility/speech-dispatcher/Makefile
@@ -19,7 +19,7 @@ USES= alias gettext gmake gnome libtool pathfix pkgconfig
USE_GNOME= glib20 intltool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-espeak-ng
-CFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -fcommon -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip