aboutsummaryrefslogtreecommitdiff
path: root/accessibility
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2020-01-02 19:46:14 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2020-01-02 19:46:14 +0000
commit941b74cdbb003e1d0742185332a9aab2e356a435 (patch)
tree4d5eb5a5c5ce63c90c3412f51ae49160eab5afdb /accessibility
parentd7993e894699a1127a741094665934dd51ce69b1 (diff)
downloadports-941b74cdbb003e1d0742185332a9aab2e356a435.tar.gz
ports-941b74cdbb003e1d0742185332a9aab2e356a435.zip
Clean up depends
Notes
Notes: svn path=/head/; revision=521871
Diffstat (limited to 'accessibility')
-rw-r--r--accessibility/caribou/Makefile2
-rw-r--r--accessibility/orca/Makefile16
2 files changed, 9 insertions, 9 deletions
diff --git a/accessibility/caribou/Makefile b/accessibility/caribou/Makefile
index 33d86dc350a9..17cb9d94b118 100644
--- a/accessibility/caribou/Makefile
+++ b/accessibility/caribou/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libclutter-glx-1.0.so:graphics/clutter \
libjson-glib-1.0.so:devel/json-glib \
libatspi.so:accessibility/at-spi2-core \
libdbus-1.so:devel/dbus
-RUN_DEPENDS= py3?-atspi>=2.1.91:accessibility/py-atspi@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}atspi>=2.1.91:accessibility/py-atspi@${PY_FLAVOR}
USES= gettext gl gmake gnome libtool localbase pathfix \
pkgconfig python:3.3+ shebangfix tar:xz xorg
diff --git a/accessibility/orca/Makefile b/accessibility/orca/Makefile
index 7eea45e7e3d4..89e76ab5d4f5 100644
--- a/accessibility/orca/Makefile
+++ b/accessibility/orca/Makefile
@@ -14,16 +14,16 @@ COMMENT= Scriptable screen reader
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= py3?-dbus>=0:devel/py-dbus@${PY_FLAVOR} \
- py3?-xdg>=0:devel/py-xdg@${PY_FLAVOR} \
- py3?-cairo>=0:graphics/py-cairo@${PY_FLAVOR} \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0:devel/py-dbus@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xdg>=0:devel/py-xdg@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cairo>=0:graphics/py-cairo@${PY_FLAVOR} \
itstool:textproc/itstool
LIB_DEPENDS= libatspi.so:accessibility/at-spi2-core
-RUN_DEPENDS= py3?-dbus>=0:devel/py-dbus@${PY_FLAVOR} \
- py3?-speech-dispatcher>=0:accessibility/py-speech-dispatcher@${PY_FLAVOR} \
- py3?-atspi>=0:accessibility/py-atspi@${PY_FLAVOR} \
- py3?-xdg>=0:devel/py-xdg@${PY_FLAVOR} \
- py3?-cairo>=0:graphics/py-cairo@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0:devel/py-dbus@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}speech-dispatcher>=0:accessibility/py-speech-dispatcher@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}atspi>=0:accessibility/py-atspi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xdg>=0:devel/py-xdg@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cairo>=0:graphics/py-cairo@${PY_FLAVOR}
# conflict with py*-json-py because orca uses the json from python itself
# and py*-json-py shadows this.