aboutsummaryrefslogtreecommitdiff
path: root/arabic/ae_fonts_ttf
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-03 11:47:23 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-03 11:47:23 +0000
commit5942db716815018583730bc97fb30772d8bc2a8f (patch)
treec1e7b8b99f7770a95adbbcb440be2085f86ffa7d /arabic/ae_fonts_ttf
parent66c7661cd97616329b97002ba5d5a292ee2e9abb (diff)
downloadports-5942db716815018583730bc97fb30772d8bc2a8f.tar.gz
ports-5942db716815018583730bc97fb30772d8bc2a8f.zip
New arabic port: ae_fonts_ttf
This port contains a collection of some of the most popular Arabic fonts created and used by the Arabic UNIX community. This truetype font set was developed at Arabeyes. PR: ports/57508 Submitted by: Samy Al Bahra <samy@kerneled.com>
Notes
Notes: svn path=/head/; revision=90096
Diffstat (limited to 'arabic/ae_fonts_ttf')
-rw-r--r--arabic/ae_fonts_ttf/Makefile78
-rw-r--r--arabic/ae_fonts_ttf/distinfo1
-rw-r--r--arabic/ae_fonts_ttf/pkg-descr9
-rw-r--r--arabic/ae_fonts_ttf/pkg-message14
-rw-r--r--arabic/ae_fonts_ttf/pkg-plist51
5 files changed, 153 insertions, 0 deletions
diff --git a/arabic/ae_fonts_ttf/Makefile b/arabic/ae_fonts_ttf/Makefile
new file mode 100644
index 000000000000..bf6406bc094f
--- /dev/null
+++ b/arabic/ae_fonts_ttf/Makefile
@@ -0,0 +1,78 @@
+# New ports collection makefile for: ae_fonts1_ttf
+# Date created: August 22 2003
+# Whom: Samy Al Bahra <samy@kerneled.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ae_fonts1_ttf
+PORTVERSION= 1.0
+CATEGORIES= x11-fonts
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= arabeyes
+DISTNAME= ae_fonts1_ttf_${PORTVERSION}
+
+MAINTAINER= samy@kerneled.com
+COMMENT= A collection of truetype Arabic fonts created by Arabeyes.org
+
+BUILD_DEPENDS= ttmkfdir:${PORTSDIR}/x11-fonts/ttmkfdir
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+WRKSRC= ${WRKDIR}/ae_fonts1
+
+.if !defined(WITHOUT_AAHS)
+FONTS= AAHS
+.endif
+
+.if !defined(WITHOUT_AGA)
+FONTS+= AGA
+.endif
+
+.if !defined(WITHOUT_FS)
+FONTS+= FS
+.endif
+
+.if !defined(WITHOUT_KASR)
+FONTS+= Kasr
+.endif
+
+.if !defined(WITHOUT_MCS)
+FONTS+= MCS
+.endif
+
+.if !defined(WITHOUT_SHMOOKH)
+FONTS+= Shmookh
+.endif
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "*****************************************************"
+ @${ECHO_MSG} "The following make variables can be set to"
+ @${ECHO_MSG} "exclude certain font sets:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "WITHOUT_AAHS - do not install the AAHS font set"
+ @${ECHO_MSG} "WITHOUT_AGA - do not install the AGA font set"
+ @${ECHO_MSG} "WITHOUT_FS - do not install the FS font set"
+ @${ECHO_MSG} "WITHOUT_KASR - do not install the Kasr font set"
+ @${ECHO_MSG} "WITHOUT_MCS - do not install the MCS font set"
+ @${ECHO_MSG} "WITHOUT_SHMOOKH - do not install the Shmookh font set"
+ @${ECHO_MSG} "*****************************************************"
+ @${ECHO_MSG} ""
+
+do-build:
+.for i in ${FONTS}
+ @ttmkfdir -c -d ${WRKSRC}/${i} > ${WRKSRC}/${i}/fonts.dir
+.endfor
+
+do-install:
+.for i in ${FONTS}
+ @${MKDIR} ${PREFIX}/lib/X11/fonts/ae_fonts1/${i}
+ @${INSTALL_DATA} ${WRKSRC}/${i}/* ${PREFIX}/lib/X11/fonts/ae_fonts1/${i}
+.endfor
+
+post-install:
+ @${CAT} ${PKGMESSAGE} | ${SED} "s|X11BASE|${X11BASE}|g" \
+ | ${SED} "s|PORTNAME|ae_fonts1|g"
+
+.include <bsd.port.mk>
diff --git a/arabic/ae_fonts_ttf/distinfo b/arabic/ae_fonts_ttf/distinfo
new file mode 100644
index 000000000000..17c715035591
--- /dev/null
+++ b/arabic/ae_fonts_ttf/distinfo
@@ -0,0 +1 @@
+MD5 (ae_fonts1_ttf_1.0.tar.bz2) = 26fc4216e9ef3c4427ef37df23e61ff4
diff --git a/arabic/ae_fonts_ttf/pkg-descr b/arabic/ae_fonts_ttf/pkg-descr
new file mode 100644
index 000000000000..4e7802ca8157
--- /dev/null
+++ b/arabic/ae_fonts_ttf/pkg-descr
@@ -0,0 +1,9 @@
+This port contains a collection of some of the most
+popular Arabic fonts created and used by the Arabic
+UNIX community. This truetype font set was developed
+at Arabeyes.
+
+WWW: http://www.arabeyes.org/project.php?proj=Khotot
+
+- Samy Al Bahra
+samy@kerneled.com
diff --git a/arabic/ae_fonts_ttf/pkg-message b/arabic/ae_fonts_ttf/pkg-message
new file mode 100644
index 000000000000..2b41375081a2
--- /dev/null
+++ b/arabic/ae_fonts_ttf/pkg-message
@@ -0,0 +1,14 @@
+------------------------------------------------------------------
+ To get XFree86 to recognize your new fonts you will need to
+ add a line to your XF86Config file. Please consult XF86Config(5)
+ for more information on where to find the configuration file.
+
+ Add the following line to the "Files" section and restart XFree86.
+
+ FontPath "X11BASE/lib/X11/fonts/PORTNAME/AAHS"
+ FontPath "X11BASE/lib/X11/fonts/PORTNAME/AGA"
+ FontPath "X11BASE/lib/X11/fonts/PORTNAME/FS"
+ FontPath "X11BASE/lib/X11/fonts/PORTNAME/Kasr"
+ FontPath "X11BASE/lib/X11/fonts/PORTNAME/MCS"
+ FontPath "X11BASE/lib/X11/fonts/PORTNAME/Shmookh"
+------------------------------------------------------------------
diff --git a/arabic/ae_fonts_ttf/pkg-plist b/arabic/ae_fonts_ttf/pkg-plist
new file mode 100644
index 000000000000..355e85812561
--- /dev/null
+++ b/arabic/ae_fonts_ttf/pkg-plist
@@ -0,0 +1,51 @@
+lib/X11/fonts/ae_fonts1/Shmookh/fonts.dir
+lib/X11/fonts/ae_fonts1/Shmookh/ae_Tarablus.ttf
+lib/X11/fonts/ae_fonts1/Shmookh/ae_Sharjah.ttf
+lib/X11/fonts/ae_fonts1/Shmookh/ae_Rehan.ttf
+lib/X11/fonts/ae_fonts1/Shmookh/ae_Ouhod.ttf
+lib/X11/fonts/ae_fonts1/Shmookh/ae_Khalid.ttf
+lib/X11/fonts/ae_fonts1/Shmookh/ae_Hani.ttf
+lib/X11/fonts/ae_fonts1/Shmookh/ae_AlYermook.ttf
+lib/X11/fonts/ae_fonts1/MCS/fonts.dir
+lib/X11/fonts/ae_fonts1/MCS/ae_Tholoth.ttf
+lib/X11/fonts/ae_fonts1/MCS/ae_Hor.ttf
+lib/X11/fonts/ae_fonts1/MCS/ae_Haramain.ttf
+lib/X11/fonts/ae_fonts1/MCS/ae_Electron.ttf
+lib/X11/fonts/ae_fonts1/Kasr/fonts.dir
+lib/X11/fonts/ae_fonts1/Kasr/ae_AlMothnna.ttf
+lib/X11/fonts/ae_fonts1/Kasr/ae_AlMohanad_bold.ttf
+lib/X11/fonts/ae_fonts1/Kasr/ae_AlMateen.ttf
+lib/X11/fonts/ae_fonts1/Kasr/ae_AlManzomah.ttf
+lib/X11/fonts/ae_fonts1/Kasr/ae_AlHor.ttf
+lib/X11/fonts/ae_fonts1/Kasr/ae_AlBattar.ttf
+lib/X11/fonts/ae_fonts1/FS/fonts.dir
+lib/X11/fonts/ae_fonts1/FS/ae_Shado.ttf
+lib/X11/fonts/ae_fonts1/FS/ae_Salem.ttf
+lib/X11/fonts/ae_fonts1/FS/ae_Nice.ttf
+lib/X11/fonts/ae_fonts1/FS/ae_Metal.ttf
+lib/X11/fonts/ae_fonts1/FS/ae_Jet.ttf
+lib/X11/fonts/ae_fonts1/FS/ae_Japan.ttf
+lib/X11/fonts/ae_fonts1/FS/ae_Graph.ttf
+lib/X11/fonts/ae_fonts1/FS/ae_Arab.ttf
+lib/X11/fonts/ae_fonts1/AGA/fonts.dir
+lib/X11/fonts/ae_fonts1/AGA/ae_Sindibad.ttf
+lib/X11/fonts/ae_fonts1/AGA/ae_Rasheeq_bold.ttf
+lib/X11/fonts/ae_fonts1/AGA/ae_Petra.ttf
+lib/X11/fonts/ae_fonts1/AGA/ae_Nada.ttf
+lib/X11/fonts/ae_fonts1/AGA/ae_Mashq_bold.ttf
+lib/X11/fonts/ae_fonts1/AGA/ae_Mashq.ttf
+lib/X11/fonts/ae_fonts1/AGA/ae_Kayrawan.ttf
+lib/X11/fonts/ae_fonts1/AGA/ae_Granada.ttf
+lib/X11/fonts/ae_fonts1/AGA/ae_Furat.ttf
+lib/X11/fonts/ae_fonts1/AGA/ae_Dimnah.ttf
+lib/X11/fonts/ae_fonts1/AAHS/fonts.dir
+lib/X11/fonts/ae_fonts1/AAHS/ae_Ostorah.ttf
+lib/X11/fonts/ae_fonts1/AAHS/ae_Nagham.ttf
+lib/X11/fonts/ae_fonts1/AAHS/ae_Cortoba.ttf
+@dirrm lib/X11/fonts/ae_fonts1/Shmookh
+@dirrm lib/X11/fonts/ae_fonts1/MCS
+@dirrm lib/X11/fonts/ae_fonts1/Kasr
+@dirrm lib/X11/fonts/ae_fonts1/FS
+@dirrm lib/X11/fonts/ae_fonts1/AGA
+@dirrm lib/X11/fonts/ae_fonts1/AAHS
+@dirrm lib/X11/fonts/ae_fonts1