aboutsummaryrefslogtreecommitdiff
path: root/archivers/arc
diff options
context:
space:
mode:
authorTim Vanderhoek <hoek@FreeBSD.org>1998-06-14 23:33:25 +0000
committerTim Vanderhoek <hoek@FreeBSD.org>1998-06-14 23:33:25 +0000
commitc873c90a0ac6e1bf2cba0d8ce4a77445ff561a7b (patch)
tree60db518e9b4d848174eef3ce24b8a92440521ee6 /archivers/arc
parentf762860bf60ed818e876a6219496aeda5f619da1 (diff)
downloadports-c873c90a0ac6e1bf2cba0d8ce4a77445ff561a7b.tar.gz
ports-c873c90a0ac6e1bf2cba0d8ce4a77445ff561a7b.zip
1) Break-up the mega-patch-aa.
2) Fix install for non-root users. 3) "See work/Arc521.doc" is not considered a good pkg/DESCR. 4) install ad. doc., too.
Notes
Notes: svn path=/head/; revision=11432
Diffstat (limited to 'archivers/arc')
-rw-r--r--archivers/arc/Makefile8
-rw-r--r--archivers/arc/files/patch-aa60
-rw-r--r--archivers/arc/files/patch-ab25
-rw-r--r--archivers/arc/files/patch-ac22
-rw-r--r--archivers/arc/pkg-descr5
-rw-r--r--archivers/arc/pkg-plist2
6 files changed, 60 insertions, 62 deletions
diff --git a/archivers/arc/Makefile b/archivers/arc/Makefile
index 740382d7dcaf..739e3bca5665 100644
--- a/archivers/arc/Makefile
+++ b/archivers/arc/Makefile
@@ -3,7 +3,7 @@
# Date created: 31 Dec 1994
# Whom: ache
#
-# $Id: Makefile,v 1.6 1997/07/21 00:48:26 fenner Exp $
+# $Id: Makefile,v 1.7 1997/08/10 22:31:09 fenner Exp $
#
DISTNAME= arc521e.pl8
@@ -17,4 +17,10 @@ MAINTAINER= ache@FreeBSD.ORG
NO_WRKSUBDIR= yes
MAN1= arc.1
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/arc ${WRKSRC}/marc ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/arc.1 ${PREFIX}/man/man1
+ ${MKDIR} ${PREFIX}/share/doc/arc
+ ${INSTALL_DATA} ${WRKSRC}/Arc521.doc ${PREFIX}/share/doc/arc
+
.include <bsd.port.mk>
diff --git a/archivers/arc/files/patch-aa b/archivers/arc/files/patch-aa
index 5b2f9b52c5c0..2ba6172e6ff3 100644
--- a/archivers/arc/files/patch-aa
+++ b/archivers/arc/files/patch-aa
@@ -32,63 +32,3 @@
# Files needed for System V
#SYSVOBJ = getwd.o rename.o scandir.o utimes.o
-***************
-*** 61,66 ****
---- 62,71 ----
-
- clean:
- -rm *.o arc$(PROG) marc$(PROG)
-+
-+ install:
-+ install -cs -o bin -g bin arc marc ${PREFIX}/bin
-+ install -c -o bin -g bin arc.1 ${PREFIX}/man/man1
-
- arc.o: $(SRCDIR)arc.c $(HEADER)
- $(CC) $(CFLAGS) -c $(SRCDIR)arc.c
-*** arcdos.c.old Wed Apr 15 02:58:21 1992
---- arcdos.c Sat Dec 31 20:32:25 1994
-***************
-*** 173,186 ****
---- 173,192 ----
- struct tm tm;
- struct timeval tvp[2];
- int utimes();
-+ #if !defined(__FreeSBD__) && !defined(__OpenBSD__)
- long tmclock();
-+ #endif
- tm.tm_sec = (time & 31) * 2;
- tm.tm_min = (time >> 5) & 63;
- tm.tm_hour = (time >> 11);
- tm.tm_mday = date & 31;
- tm.tm_mon = ((date >> 5) & 15) - 1;
- tm.tm_year = (date >> 9) + 80;
-+ #if !defined(__FreeBSD__) && !defined(__OpenBSD__) && !defined(__NetBSD__)
- tvp[0].tv_sec = tmclock(&tm);
-+ #else
-+ tvp[0].tv_sec = timelocal(&tm);
-+ #endif
- tvp[1].tv_sec = tvp[0].tv_sec;
- tvp[0].tv_usec = tvp[1].tv_usec = 0;
- utimes(f, tvp);
-*** marc.c.old Wed Apr 15 02:59:21 1992
---- marc.c Sat Dec 31 20:40:30 1994
-***************
-*** 35,40 ****
---- 35,41 ----
- #endif
- VOID arcdie();
- static VOID expandlst(), merge();
-+ char *makefnam(); /* filename fixup routine */
-
- FILE *src; /* source archive */
- char srcname[STRLEN]; /* source archive name */
-***************
-*** 47,53 ****
- int nargs; /* number of arguments */
- char *arg[]; /* pointers to arguments */
- {
-- char *makefnam(); /* filename fixup routine */
- char *envfind();
- #if !_MTS
- char *arctemp2, *mktemp(); /* temp file stuff */
---- 48,53 ----
diff --git a/archivers/arc/files/patch-ab b/archivers/arc/files/patch-ab
new file mode 100644
index 000000000000..b55cbaa6c144
--- /dev/null
+++ b/archivers/arc/files/patch-ab
@@ -0,0 +1,25 @@
+*** arcdos.c.old Wed Apr 15 02:58:21 1992
+--- arcdos.c Sat Dec 31 20:32:25 1994
+***************
+*** 173,186 ****
+--- 173,192 ----
+ struct tm tm;
+ struct timeval tvp[2];
+ int utimes();
++ #if !defined(__FreeSBD__) && !defined(__OpenBSD__)
+ long tmclock();
++ #endif
+ tm.tm_sec = (time & 31) * 2;
+ tm.tm_min = (time >> 5) & 63;
+ tm.tm_hour = (time >> 11);
+ tm.tm_mday = date & 31;
+ tm.tm_mon = ((date >> 5) & 15) - 1;
+ tm.tm_year = (date >> 9) + 80;
++ #if !defined(__FreeBSD__) && !defined(__OpenBSD__) && !defined(__NetBSD__)
+ tvp[0].tv_sec = tmclock(&tm);
++ #else
++ tvp[0].tv_sec = timelocal(&tm);
++ #endif
+ tvp[1].tv_sec = tvp[0].tv_sec;
+ tvp[0].tv_usec = tvp[1].tv_usec = 0;
+ utimes(f, tvp);
diff --git a/archivers/arc/files/patch-ac b/archivers/arc/files/patch-ac
new file mode 100644
index 000000000000..42c9f08b17da
--- /dev/null
+++ b/archivers/arc/files/patch-ac
@@ -0,0 +1,22 @@
+*** marc.c.old Wed Apr 15 02:59:21 1992
+--- marc.c Sat Dec 31 20:40:30 1994
+***************
+*** 35,40 ****
+--- 35,41 ----
+ #endif
+ VOID arcdie();
+ static VOID expandlst(), merge();
++ char *makefnam(); /* filename fixup routine */
+
+ FILE *src; /* source archive */
+ char srcname[STRLEN]; /* source archive name */
+***************
+*** 47,53 ****
+ int nargs; /* number of arguments */
+ char *arg[]; /* pointers to arguments */
+ {
+- char *makefnam(); /* filename fixup routine */
+ char *envfind();
+ #if !_MTS
+ char *arctemp2, *mktemp(); /* temp file stuff */
+--- 48,53 ----
diff --git a/archivers/arc/pkg-descr b/archivers/arc/pkg-descr
index 004178c9f687..f91ee3211816 100644
--- a/archivers/arc/pkg-descr
+++ b/archivers/arc/pkg-descr
@@ -1 +1,4 @@
-See the file work/Arc521.doc for more info .
+This package creates and extracts-from ARC archives. An ARC archive
+contains files which are compressed according to the most efficient
+of three algorythms. ARC archives are usually only used for compatibility
+with MS-DOS.
diff --git a/archivers/arc/pkg-plist b/archivers/arc/pkg-plist
index 4565b4702114..4087431da9c2 100644
--- a/archivers/arc/pkg-plist
+++ b/archivers/arc/pkg-plist
@@ -1,3 +1,5 @@
bin/arc
bin/marc
man/man1/arc.1.gz
+share/doc/arc/Arc521.doc
+@dirrm share/doc/arc