aboutsummaryrefslogtreecommitdiff
path: root/archivers/arj
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2019-11-07 11:58:29 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2019-11-07 11:58:29 +0000
commit170bbdd62c25aa4b6a1a685edec46e6a39d208e5 (patch)
treebde73c4d541145c7bb6b036c8aca0a064aa7ba42 /archivers/arj
parent231efba085530a3d1869216b0726e68d1e2b3c01 (diff)
downloadports-170bbdd62c25aa4b6a1a685edec46e6a39d208e5.tar.gz
ports-170bbdd62c25aa4b6a1a685edec46e6a39d208e5.zip
Catch up with the latest Debian patchset to unbreak the fetch.
Notes
Notes: svn path=/head/; revision=516966
Diffstat (limited to 'archivers/arj')
-rw-r--r--archivers/arj/Makefile2
-rw-r--r--archivers/arj/distinfo4
-rw-r--r--archivers/arj/files/patch-arjtypes.c2
3 files changed, 4 insertions, 4 deletions
diff --git a/archivers/arj/Makefile b/archivers/arj/Makefile
index dac7a5e498f9..74149426d39c 100644
--- a/archivers/arj/Makefile
+++ b/archivers/arj/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= archivers
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/2.78_3.10%20build%2022:source \
DEBIAN_POOL:patch
DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz:source \
- ${PORTNAME}_${PORTVERSION}-21.debian.tar.xz:patch
+ ${PORTNAME}_${PORTVERSION}-23.debian.tar.xz:patch
MAINTAINER= garga@FreeBSD.org
COMMENT= Open source implementation of the ARJ archiver
diff --git a/archivers/arj/distinfo b/archivers/arj/distinfo
index 2291d5d420fd..b1dbc8c3c875 100644
--- a/archivers/arj/distinfo
+++ b/archivers/arj/distinfo
@@ -1,5 +1,5 @@
TIMESTAMP = 1563302294
SHA256 (arj-3.10.22.tar.gz) = 589e4c9bccc8669e7b6d8d6fcd64e01f6a2c21fe10aad56a83304ecc3b96a7db
SIZE (arj-3.10.22.tar.gz) = 431467
-SHA256 (arj_3.10.22-21.debian.tar.xz) = 20c430f4222b8d75d1b2a6d435620f024c41a30dbc3949890c63686a7497f61e
-SIZE (arj_3.10.22-21.debian.tar.xz) = 21768
+SHA256 (arj_3.10.22-23.debian.tar.xz) = d3e5c0e5d2f7be61a177d6606077663b5cd742380c2c5a69763baaca770e64a8
+SIZE (arj_3.10.22-23.debian.tar.xz) = 22832
diff --git a/archivers/arj/files/patch-arjtypes.c b/archivers/arj/files/patch-arjtypes.c
index c0aad52e404b..0c4ebc246216 100644
--- a/archivers/arj/files/patch-arjtypes.c
+++ b/archivers/arj/files/patch-arjtypes.c
@@ -6,7 +6,7 @@
struct tm *stm;
+ time_t _ts;
-- stm=arj_localtime((time_t*)&ts);
+- stm=arj_localtime(&ts);
+ _ts = ts;
+
+ stm=arj_localtime(&_ts);