aboutsummaryrefslogtreecommitdiff
path: root/archivers/arj
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-06-25 03:23:59 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-06-25 03:23:59 +0000
commit52919007a995d44a7926bcdfb06fe8d2157b120e (patch)
treec432869cf5fb01f2c4507af6c618d62add233756 /archivers/arj
parent34ab7e2742ee2a66707f6afcb782318a40b95a1f (diff)
downloadports-52919007a995d44a7926bcdfb06fe8d2157b120e.tar.gz
ports-52919007a995d44a7926bcdfb06fe8d2157b120e.zip
- Remove BROKEN_powerpc, builds and runs just fine (tested on Mac mini G4)
- Avoid changing the same file both via the patch and with sed(1) - Now that with staging PLIST_FILES become long again, resurrect pkg-plist - Improve COMMENT, port description, sort the knobs, and cleanup the port
Notes
Notes: svn path=/head/; revision=359180
Diffstat (limited to 'archivers/arj')
-rw-r--r--archivers/arj/Makefile37
-rw-r--r--archivers/arj/files/patch-fardata.c20
-rw-r--r--archivers/arj/pkg-descr19
-rw-r--r--archivers/arj/pkg-plist10
4 files changed, 51 insertions, 35 deletions
diff --git a/archivers/arj/Makefile b/archivers/arj/Makefile
index 707dc8d2c60e..fd9781d1ab64 100644
--- a/archivers/arj/Makefile
+++ b/archivers/arj/Makefile
@@ -8,51 +8,38 @@ CATEGORIES= archivers
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/2.78_3.10%20build%2022
MAINTAINER= garga@FreeBSD.org
-COMMENT= Open-source ARJ
+COMMENT= Open source implementation of the ARJ archiver
LICENSE= GPLv2
-OPTIONS_DEFINE= DOCS
+PORTSCOUT= skipv:3.10g
USES= gmake
USE_AUTOTOOLS= autoconf
-MAKE_JOBS_UNSAFE= yes
CONFIGURE_WRKSRC= ${WRKSRC}/gnu
-CFLAGS+= -fPIC
MAKEFILE= GNUmakefile
-STRIP=
-LANGUAGE?= en
-MAKE_ARGS+= "LOCALE=${LANGUAGE}"
+MAKE_ARGS= LOCALE="${LANGUAGE}"
ALL_TARGET= prepare all
+STRIP= # empty
-PORTDOCS= *
-
-PLIST_FILES= bin/arj \
- bin/arj-register \
- bin/arjdisp \
- bin/rearj \
- lib/arj/arjcrypt.so \
- man/man1/arj-register.1.gz \
- man/man1/arj.1.gz \
- man/man1/arjdisp.1.gz \
- man/man1/rearj.1.gz
-PLIST_DIRS= lib/arj
+CFLAGS+= -fPIC
+LANGUAGE?= en
-PORTSCOUT= skipv:3.10g
+PORTDOCS= *
-BROKEN_powerpc= Does not install on powerpc
+OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e 's!/etc!${LOCALBASE}/etc!' \
${WRKSRC}/arj.c ${WRKSRC}/file_reg.c ${WRKSRC}/rearj.c
@${REINPLACE_CMD} -e 's!-O2!!' ${WRKSRC}/gnu/configure.in
@${REINPLACE_CMD} -e 's!^static !!' ${WRKSRC}/integr.c
- @${REINPLACE_CMD} -e 's!strnlen!_strnlen!g' ${WRKSRC}/fardata.c
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC}/doc && ${INSTALL_DATA} COPYING debug.txt ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC}/resource/en && \
- ${INSTALL_DATA} arjl.txt arjs.txt history.txt readme.txt unix.txt ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/doc && ${INSTALL_DATA} COPYING debug.txt \
+ ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/resource/en && ${INSTALL_DATA} arjl.txt arjs.txt \
+ history.txt readme.txt unix.txt ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/archivers/arj/files/patch-fardata.c b/archivers/arj/files/patch-fardata.c
index eaacfdd1e36a..0b9163f954f2 100644
--- a/archivers/arj/files/patch-fardata.c
+++ b/archivers/arj/files/patch-fardata.c
@@ -1,6 +1,24 @@
--- fardata.c.orig 2010-01-18 10:06:57.000000000 -0200
+++ fardata.c 2010-01-18 10:08:24.000000000 -0200
-@@ -655,7 +655,7 @@
+@@ -190,7 +190,7 @@ int msg_sprintf(char *str, FMSG *fmt, ..
+
+ /* Length-limited strlen() */
+
+-static int strnlen(const char FAR *s, int count)
++static int _strnlen(const char FAR *s, int count)
+ {
+ const char FAR *sc;
+
+@@ -569,7 +569,7 @@ int vcprintf(int ccode, FMSG *fmt, va_li
+ if(!s)
+ s="(null)";
+ #endif
+- len=strnlen(s, precision);
++ len=_strnlen(s, precision);
+ if(!(flags&LEFT))
+ {
+ while(len<field_width--)
+@@ -655,7 +655,7 @@ int vcprintf(int ccode, FMSG *fmt, va_li
num=va_arg(args, unsigned long);
else if(qualifier=='h')
{
diff --git a/archivers/arj/pkg-descr b/archivers/arj/pkg-descr
index 61f3bf613d42..8d1a1b0f49dd 100644
--- a/archivers/arj/pkg-descr
+++ b/archivers/arj/pkg-descr
@@ -1,13 +1,14 @@
-This product is an implementation of ARJ v 2.7x for DOS on UNIX and
-UNIX-like systems. It is assumed that the user is familiar with ARJ
-operation on DOS before using this package.
+This is open source implementation of the world-famous ARJ archiver. This
+version has been created with an intent to preserve maximum compatibility
+and retain the feature set of the original ARJ archiver as provided by ARJ
+Software, Inc.
-New ARJ features on UNIX and UNIX-like platforms:
+New ARJ features on Unix-like platforms:
- - Support for symbolic and hard links
- - Archiving of special entities: pipes and devices
- - Support for UID/GID storage in a variety of methods
- - World's smallest native self-extracting modules
- - Outstanding interoperability with ARJ for DOS, Windows and OS/2 Warp
+ - Support for symbolic and hard links
+ - Archiving of special entities: pipes and devices
+ - Support for UID/GID storage in a variety of methods
+ - World's smallest native self-extracting modules
+ - Interoperability with ARJ for DOS, Windows, and OS/2 Warp
WWW: http://arj.sourceforge.net/
diff --git a/archivers/arj/pkg-plist b/archivers/arj/pkg-plist
new file mode 100644
index 000000000000..60b84a23b793
--- /dev/null
+++ b/archivers/arj/pkg-plist
@@ -0,0 +1,10 @@
+bin/arj
+bin/arj-register
+bin/arjdisp
+bin/rearj
+lib/arj/arjcrypt.so
+man/man1/arj-register.1.gz
+man/man1/arj.1.gz
+man/man1/arjdisp.1.gz
+man/man1/rearj.1.gz
+@dirrm lib/arj