aboutsummaryrefslogtreecommitdiff
path: root/archivers/arj
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2017-11-13 12:12:08 +0000
committerRenato Botelho <garga@FreeBSD.org>2017-11-13 12:12:08 +0000
commitc0432317fe38c42c5cba2a8edee31e77593a6fd2 (patch)
treeb201c2547c41a96166ec9709b254211e6cb169f7 /archivers/arj
parent078ac90e1cbcaced3d5ca72af17d1e286e892d06 (diff)
downloadports-c0432317fe38c42c5cba2a8edee31e77593a6fd2.tar.gz
ports-c0432317fe38c42c5cba2a8edee31e77593a6fd2.zip
- Add LLD_UNSAFE to fix build with WITH_LLD_IS_LD [1]
- Create OPTIONS to set possible languages to be used at build time instead of using LOCALE environment variable [2] - While here, pet portlint - Bump PORTREVISION PR: 219716 [1], 223259 [2] Submitted by: ed@ [1], Matt <fsbruva@yahoo.com> [2] Reported by: O. Hartmann <iohartmann@walstatt.org> [1] Sponsored by: Rubicon Communications, LLC (Netgate)
Notes
Notes: svn path=/head/; revision=454107
Diffstat (limited to 'archivers/arj')
-rw-r--r--archivers/arj/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/archivers/arj/Makefile b/archivers/arj/Makefile
index 571bfee72814..7062001b6bd2 100644
--- a/archivers/arj/Makefile
+++ b/archivers/arj/Makefile
@@ -3,7 +3,7 @@
PORTNAME= arj
PORTVERSION= 3.10.22
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= archivers
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/2.78_3.10%20build%2022:source \
DEBIAN_POOL:patch
@@ -15,9 +15,6 @@ COMMENT= Open source implementation of the ARJ archiver
LICENSE= GPLv2
-PORTSCOUT= skipv:3.10g
-
-EXTRA_PATCHES= ${WRKDIR}/debian/patches/*.patch
IGNORE_PATCHES= 002_no_remove_static_const.patch \
doc_refer_robert_k_jung.patch \
gnu_build_cross.patch \
@@ -26,22 +23,35 @@ IGNORE_PATCHES= 002_no_remove_static_const.patch \
gnu_build_pie.patch \
gnu_build_strip.patch \
hurd_no_fcntl_getlk.patch
+
+EXTRA_PATCHES= ${WRKDIR}/debian/patches/*.patch
PATCH_STRIP= -p1
+PORTSCOUT= skipv:3.10g
+
USES= alias gmake
USE_AUTOTOOLS= autoconf
CONFIGURE_WRKSRC= ${WRKSRC}/gnu
MAKEFILE= GNUmakefile
-MAKE_ARGS= LOCALE="${LANGUAGE}"
ALL_TARGET= prepare all
STRIP= # empty
+LLD_UNSAFE= yes
CFLAGS+= -fPIC
-LANGUAGE?= en
PORTDOCS= *
OPTIONS_DEFINE= DOCS
+OPTIONS_SINGLE= LOCALE
+OPTIONS_SINGLE_LOCALE= LOCALE_DE LOCALE_EN LOCALE_RU
+OPTIONS_DEFAULT=LOCALE_EN
+LOCALE_DESC= Select language to define at build time
+LOCALE_DE_DESC= German
+LOCALE_EN_DESC= English
+LOCALE_RU_DESC= Russian
+LOCALE_DE_MAKE_ARGS= LOCALE=de
+LOCALE_EN_MAKE_ARGS= LOCALE=en
+LOCALE_RU_MAKE_ARGS= LOCALE=ru
pre-patch:
@${RM} ${IGNORE_PATCHES:S,^,${WRKDIR}/debian/patches/,}