aboutsummaryrefslogtreecommitdiff
path: root/archivers/atool
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-11-04 16:57:20 +0000
committerJohn Marino <marino@FreeBSD.org>2014-11-04 16:57:20 +0000
commitcea8b47d653ef9fcf0148d0f5b72e749dc52c6e8 (patch)
tree9cea7fd84befdb65b169d6d9be50c19d7fc1b4cb /archivers/atool
parent1e03c74b0fe0671e033115ea62d007437a6df559 (diff)
downloadports-cea8b47d653ef9fcf0148d0f5b72e749dc52c6e8.tar.gz
ports-cea8b47d653ef9fcf0148d0f5b72e749dc52c6e8.zip
Add new port archivers/atool
PR: 194082 Submitted by: Matteo Cypriani atool is a script for managing file archives of various types (tar, tar+gzip, zip, etc.). It provides the following commands: * aunpack: extract an archive, avoiding tar bombs * als: list the contents of an archive * acat: extract files to the standard output * apack: create an archive Optional dependencies: lbzip2 or pbzip2, lzip, plzip, lzop, lzma, zip, unzip, unrar, lha, unace, arj, arc, nomarch, p7zip, unalz.
Notes
Notes: svn path=/head/; revision=372154
Diffstat (limited to 'archivers/atool')
-rw-r--r--archivers/atool/Makefile18
-rw-r--r--archivers/atool/distinfo2
-rw-r--r--archivers/atool/files/patch-configure11
-rw-r--r--archivers/atool/pkg-descr12
-rw-r--r--archivers/atool/pkg-plist14
5 files changed, 57 insertions, 0 deletions
diff --git a/archivers/atool/Makefile b/archivers/atool/Makefile
new file mode 100644
index 000000000000..8a3c34c82f86
--- /dev/null
+++ b/archivers/atool/Makefile
@@ -0,0 +1,18 @@
+# Created by: Matteo Cypriani <mcy@lm7.fr>
+# $FreeBSD$
+
+PORTNAME= atool
+PORTVERSION= 0.39.0
+CATEGORIES= archivers
+MASTER_SITES= SAVANNAH
+
+MAINTAINER= mcy@lm7.fr
+COMMENT= Manage file archives of various types
+
+LICENSE= GPLv2
+
+GNU_CONFIGURE= yes
+USES= gmake perl5
+USE_PERL5= build run
+
+.include <bsd.port.mk>
diff --git a/archivers/atool/distinfo b/archivers/atool/distinfo
new file mode 100644
index 000000000000..8400cfea7d6b
--- /dev/null
+++ b/archivers/atool/distinfo
@@ -0,0 +1,2 @@
+SHA256 (atool-0.39.0.tar.gz) = aaf60095884abb872e25f8e919a8a63d0dabaeca46faeba87d12812d6efc703b
+SIZE (atool-0.39.0.tar.gz) = 119307
diff --git a/archivers/atool/files/patch-configure b/archivers/atool/files/patch-configure
new file mode 100644
index 000000000000..3460043639a9
--- /dev/null
+++ b/archivers/atool/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2012-02-21 18:14:06 UTC
++++ configure
+@@ -2261,7 +2261,7 @@
+
+
+ eval `$PERL -V:startperl`
+-if test "${startperl:0:1}" = "#" ; then
++if test "$(echo ${startperl} | awk '{ string=substr($0, 1, 1); print string; }')" = "#" ; then
+ startperl="\\$startperl"
+ fi
+ PERL_SHEBANG=$startperl
diff --git a/archivers/atool/pkg-descr b/archivers/atool/pkg-descr
new file mode 100644
index 000000000000..451cd1eb4564
--- /dev/null
+++ b/archivers/atool/pkg-descr
@@ -0,0 +1,12 @@
+atool is a script for managing file archives of various types (tar,
+tar+gzip, zip, etc.). It provides the following commands:
+
+ * aunpack: extract an archive, avoiding tar bombs
+ * als: list the contents of an archive
+ * acat: extract files to the standard output
+ * apack: create an archive
+
+Optional dependencies: lbzip2 or pbzip2, lzip, plzip, lzop, lzma, zip,
+unzip, unrar, lha, unace, arj, arc, nomarch, p7zip, unalz.
+
+WWW: http://www.nongnu.org/atool/
diff --git a/archivers/atool/pkg-plist b/archivers/atool/pkg-plist
new file mode 100644
index 000000000000..4f3837b76aae
--- /dev/null
+++ b/archivers/atool/pkg-plist
@@ -0,0 +1,14 @@
+bin/acat
+bin/adiff
+bin/als
+bin/apack
+bin/arepack
+bin/atool
+bin/aunpack
+man/man1/acat.1.gz
+man/man1/adiff.1.gz
+man/man1/als.1.gz
+man/man1/apack.1.gz
+man/man1/arepack.1.gz
+man/man1/atool.1.gz
+man/man1/aunpack.1.gz