aboutsummaryrefslogtreecommitdiff
path: root/archivers/bicom
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2009-03-30 09:33:56 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2009-03-30 09:33:56 +0000
commit82e4a78c1cbb39d6e55dcbd497054104dc9c892b (patch)
tree1ea00cedf9fc6c2a40a5ee24f2c4bd124b57e617 /archivers/bicom
parentb970f527bf49c27e7342cd3213aa9789f8190d8c (diff)
downloadports-82e4a78c1cbb39d6e55dcbd497054104dc9c892b.tar.gz
ports-82e4a78c1cbb39d6e55dcbd497054104dc9c892b.zip
- Fix files/Makefile and mark the port as MAKE_JOBS_SAFE
- Cleanup Makefile - Drop maintainership
Notes
Notes: svn path=/head/; revision=231296
Diffstat (limited to 'archivers/bicom')
-rw-r--r--archivers/bicom/Makefile7
-rw-r--r--archivers/bicom/files/Makefile4
2 files changed, 6 insertions, 5 deletions
diff --git a/archivers/bicom/Makefile b/archivers/bicom/Makefile
index 4b258837a221..e472e69fa473 100644
--- a/archivers/bicom/Makefile
+++ b/archivers/bicom/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: bicom
+# New ports collection makefile for: BIjective COMpressor
# Date created: 09 May 2003
# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
#
@@ -10,15 +10,16 @@ PORTVERSION= 1.01
CATEGORIES= archivers
MASTER_SITES= http://www3.sympatico.ca/mt0000/bicom/ \
http://freebsd.nsu.ru/distfiles/
-DISTNAME= ${PORTNAME}101
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
-MAINTAINER= danfe@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Data compressor in the PPM family
RESTRICTED= Contact author personally regarding commercial use
NO_WRKSUBDIR= yes
MAKEFILE= ${FILESDIR}/Makefile
+MAKE_JOBS_SAFE= YES
PLIST_FILES= bin/bicom
USE_ZIP= yes
diff --git a/archivers/bicom/files/Makefile b/archivers/bicom/files/Makefile
index c3513cefdd53..6c5cdb2994c2 100644
--- a/archivers/bicom/files/Makefile
+++ b/archivers/bicom/files/Makefile
@@ -16,10 +16,10 @@ OBJS = bialib/mtstream.o \
bicom/bicom.o
.cpp.o:
- ${CXX} ${CXXFLAGS} ${IDIR} -c $< -o $*.o
+ ${CXX} ${CXXFLAGS} ${IDIR} -o $@ -c $<
all: ${OBJS}
- ${CXX} ${CXXFLAGS} -o bicom/bicom ${OBJS}
+ ${CXX} ${CXXFLAGS} -o bicom/bicom $>
clean:
rm -f bicom/bicom bicom/*.o bialib/*.o core