aboutsummaryrefslogtreecommitdiff
path: root/archivers/bicom
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-05-09 19:04:41 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-05-09 19:04:41 +0000
commit9f1e9bf443457eb30eac4427ee9cdc35b30062ae (patch)
tree2c9b2af8a6e5257b550ed87c9da52cb6d2597954 /archivers/bicom
parent751000fc4323bb80f1546d65386a33d7bb875fb5 (diff)
downloadports-9f1e9bf443457eb30eac4427ee9cdc35b30062ae.tar.gz
ports-9f1e9bf443457eb30eac4427ee9cdc35b30062ae.zip
New port: bicom
Data compressor in the PPM family. Submitted by: Alexey Dokuchaev
Notes
Notes: svn path=/head/; revision=80560
Diffstat (limited to 'archivers/bicom')
-rw-r--r--archivers/bicom/Makefile28
-rw-r--r--archivers/bicom/distinfo1
-rw-r--r--archivers/bicom/files/Makefile25
-rw-r--r--archivers/bicom/pkg-descr11
-rw-r--r--archivers/bicom/pkg-plist1
5 files changed, 66 insertions, 0 deletions
diff --git a/archivers/bicom/Makefile b/archivers/bicom/Makefile
new file mode 100644
index 000000000000..2992272507b5
--- /dev/null
+++ b/archivers/bicom/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: bicom
+# Date created: 09 May 2003
+# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bicom
+PORTVERSION= 1.01
+CATEGORIES= archivers
+MASTER_SITES= http://www3.sympatico.ca/mt0000/bicom/ \
+ http://freebsd.nsu.ru/distfiles/
+DISTNAME= ${PORTNAME}101
+
+MAINTAINER= danfe@regency.nsu.ru
+COMMENT= Data compressor in the PPM family
+
+RESTRICTED= "Contact author personally regarding commercial use"
+
+NO_WRKSUBDIR= yes
+MAKEFILE= ${FILESDIR}/Makefile
+
+USE_ZIP= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bicom/bicom ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/archivers/bicom/distinfo b/archivers/bicom/distinfo
new file mode 100644
index 000000000000..0b565c9582ee
--- /dev/null
+++ b/archivers/bicom/distinfo
@@ -0,0 +1 @@
+MD5 (bicom101.zip) = 6d07af1f3255012944777c43e8224d3f
diff --git a/archivers/bicom/files/Makefile b/archivers/bicom/files/Makefile
new file mode 100644
index 000000000000..cb573ac27a74
--- /dev/null
+++ b/archivers/bicom/files/Makefile
@@ -0,0 +1,25 @@
+#
+# $FreeBSD$
+#
+
+CCX = c++
+
+IDIR = -I./bialib
+
+OBJS = bialib/mtstream.o \
+ bialib/simplemodel.o \
+ bialib/arithmetic.o \
+ bialib/trivial.o \
+ bialib/sufftree.o \
+ bialib/exclude.o \
+ bialib/rijndael.o \
+ bicom/bicom.o
+
+.cpp.o:
+ ${CCX} ${CXXFLAGS} ${IDIR} -c $< -o $*.o
+
+all: ${OBJS}
+ ${CCX} ${CXXFLAGS} -o bicom/bicom ${OBJS}
+
+clean:
+ rm -f bicom/bicom bicom/*.o bialib/*.o core
diff --git a/archivers/bicom/pkg-descr b/archivers/bicom/pkg-descr
new file mode 100644
index 000000000000..0d8b1e9dadd0
--- /dev/null
+++ b/archivers/bicom/pkg-descr
@@ -0,0 +1,11 @@
+Bicom is a data compressor in the PPM family. It is freely available and
+Open Source. It's most unique characteristic, is that compression with
+bicom is completely bijective -- any file is a possible bicom output that
+can be decompressed, and then recompressed back to its original form. Of
+course, any file is also a possible bicom input that can be compressed,
+and then decompressed back to its original form. To support encryption
+applications, bicom also includes a passphrase-protection option that
+will automatically encrypt after compressing, or decrypt before
+decompressing.
+
+WWW: http://www3.sympatico.ca/mt0000/bicom/
diff --git a/archivers/bicom/pkg-plist b/archivers/bicom/pkg-plist
new file mode 100644
index 000000000000..0bb863ec3b27
--- /dev/null
+++ b/archivers/bicom/pkg-plist
@@ -0,0 +1 @@
+bin/bicom