aboutsummaryrefslogtreecommitdiff
path: root/archivers/bzip2
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-02-22 13:21:22 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-02-22 13:21:22 +0000
commit8bf307c65183d1812cdb4cc0f723c5f792874149 (patch)
tree9ea7f8972906e35d8b1ea68589782d61b377913f /archivers/bzip2
parentde0e10d4754c6424e4867a1559974dcc678b2888 (diff)
downloadports-8bf307c65183d1812cdb4cc0f723c5f792874149.tar.gz
ports-8bf307c65183d1812cdb4cc0f723c5f792874149.zip
- Update to bzip 1.0.2, request maintainership
PR: 34968 Submitted by: jharris@widomaker.com
Notes
Notes: svn path=/head/; revision=55083
Diffstat (limited to 'archivers/bzip2')
-rw-r--r--archivers/bzip2/Makefile21
-rw-r--r--archivers/bzip2/distinfo2
-rw-r--r--archivers/bzip2/files/patch-aa47
-rw-r--r--archivers/bzip2/pkg-descr2
-rw-r--r--archivers/bzip2/pkg-plist10
5 files changed, 53 insertions, 29 deletions
diff --git a/archivers/bzip2/Makefile b/archivers/bzip2/Makefile
index 8a58d6c6777c..c1928f39c43f 100644
--- a/archivers/bzip2/Makefile
+++ b/archivers/bzip2/Makefile
@@ -7,12 +7,12 @@
#
PORTNAME= bzip2
-PORTVERSION= 1.0.1
+PORTVERSION= 1.0.2
CATEGORIES= archivers
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
-MASTER_SITE_SUBDIR= bzip2/v100
+MASTER_SITE_SUBDIR= bzip2/v102
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= jharris@widomaker.com
.if exists(/usr/bin/bzip2)
IGNORE= bzip2 is in the base system
@@ -20,9 +20,12 @@ IGNORE= bzip2 is in the base system
INSTALLS_SHLIB= yes
-MAN1= bzip2.1
+MAN1= bzip2.1 bzgrep.1 bzmore.1
MLINKS= bzip2.1 bunzip2.1 bzip2.1 bzcat.1 bzip2.1 bz2cat.1 \
- bzip2.1 bzip2recover.1
+ bzip2.1 bzip2recover.1 \
+ bzgrep.1 bzegrep.1 \
+ bzgrep.1 bzfgrep.1 \
+ bzmore.1 bzless.1
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bzip2 ${PREFIX}/bin
@@ -30,14 +33,22 @@ do-install:
${LN} -sf ${PREFIX}/bin/bzip2 ${PREFIX}/bin/bzcat
${LN} -sf ${PREFIX}/bin/bzip2 ${PREFIX}/bin/bz2cat
${INSTALL_PROGRAM} ${WRKSRC}/bzip2recover ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/bzgrep ${PREFIX}/bin
+ ${LN} -sf ${PREFIX}/bin/bzgrep ${PREFIX}/bin/bzegrep
+ ${LN} -sf ${PREFIX}/bin/bzgrep ${PREFIX}/bin/bzfgrep
+ ${INSTALL_SCRIPT} ${WRKSRC}/bzmore ${PREFIX}/bin
+ ${LN} -sf ${PREFIX}/bin/bzmore ${PREFIX}/bin/bzless
${INSTALL_DATA} ${WRKSRC}/bzlib.h ${PREFIX}/include
${INSTALL_DATA} ${WRKSRC}/libbz2.a ${PREFIX}/lib
${INSTALL_DATA} ${WRKSRC}/libbz2.so.1 ${PREFIX}/lib
${LN} -sf ${PREFIX}/lib/libbz2.so.1 ${PREFIX}/lib/libbz2.so
${INSTALL_MAN} ${WRKSRC}/bzip2.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/bzgrep.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/bzmore.1 ${PREFIX}/man/man1
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/bzip2
${INSTALL_DATA} ${WRKSRC}/manual* ${PREFIX}/share/doc/bzip2
+ ${INSTALL_DATA} ${WRKSRC}/bzip2.txt ${PREFIX}/share/doc/bzip2
${PREFIX}/bin/bzip2 -f ${PREFIX}/share/doc/bzip2/manual.ps
.endif
diff --git a/archivers/bzip2/distinfo b/archivers/bzip2/distinfo
index 7cf8451fd47d..5f7c4e4f617a 100644
--- a/archivers/bzip2/distinfo
+++ b/archivers/bzip2/distinfo
@@ -1 +1 @@
-MD5 (bzip2-1.0.1.tar.gz) = 770135dc94369cb3eb6013ed505c8dc5
+MD5 (bzip2-1.0.2.tar.gz) = ee76864958d568677f03db8afad92beb
diff --git a/archivers/bzip2/files/patch-aa b/archivers/bzip2/files/patch-aa
index 33419f799219..66368aedfde9 100644
--- a/archivers/bzip2/files/patch-aa
+++ b/archivers/bzip2/files/patch-aa
@@ -1,19 +1,25 @@
---- Makefile.orig Wed May 17 00:31:04 2000
-+++ Makefile Thu Jun 8 17:41:26 2000
-@@ -1,8 +1,10 @@
-
+--- Makefile 2002/02/14 03:34:07 1.1
++++ Makefile 2002/02/14 03:53:34
+@@ -2,14 +2,16 @@
SHELL=/bin/sh
+
+ # To assist in cross-compiling
-CC=gcc
+CC?=gcc
+ AR=ar
+ RANLIB=ranlib
+ LDFLAGS=
+
+ # Suitably paranoid flags to avoid bugs in gcc-2.7
BIGFILES=-D_FILE_OFFSET_BITS=64
-CFLAGS=-Wall -Winline -O2 -fomit-frame-pointer -fno-strength-reduce $(BIGFILES)
+CFLAGS?=-O2
+CFLAGS+=-Wall -Winline -fomit-frame-pointer -fno-strength-reduce $(BIGFILES)
+SOFLAGS=-fPIC -fpic -DPIC
- OBJS= blocksort.o \
- huffman.o \
-@@ -12,10 +14,18 @@
+ # Where you want it installed when you do 'make install'
+ PREFIX=/usr
+@@ -23,10 +25,18 @@
decompress.o \
bzlib.o
@@ -27,37 +33,36 @@
+ bzlib.so
-bzip2: libbz2.a bzip2.o
-- $(CC) $(CFLAGS) -o bzip2 bzip2.o -L. -lbz2
+- $(CC) $(CFLAGS) $(LDFLAGS) -o bzip2 bzip2.o -L. -lbz2
+all: libbz2.so.1 libbz2.a bzip2 bzip2recover test
+
+bzip2: libbz2.so.1 libbz2.a bzip2.o
+ $(CC) $(CFLAGS) -o bzip2 bzip2.o libbz2.a
bzip2recover: bzip2recover.o
- $(CC) $(CFLAGS) -o bzip2recover bzip2recover.o
-@@ -29,6 +39,10 @@
- ranlib libbz2.a ; \
+ $(CC) $(CFLAGS) $(LDFLAGS) -o bzip2recover bzip2recover.o
+@@ -40,6 +50,10 @@
+ $(RANLIB) libbz2.a ; \
fi
+libbz2.so.1: $(SO_OBJS)
+ $(CC) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1 $(SO_OBJS)
+ ln -sf libbz2.so.1 libbz2.so
+
+ check: test
test: bzip2
@cat words1
- ./bzip2 -1 < sample1.ref > sample1.rb2
-@@ -69,12 +83,27 @@
- chmod a+r $(PREFIX)/lib/libbz2.a
+@@ -98,9 +112,25 @@
+ distclean: clean
clean:
- rm -f *.o libbz2.a bzip2 bzip2recover \
+ rm -f *.o *.so libbz2.a libbz2.so.1 bzip2 bzip2recover \
sample1.rb2 sample2.rb2 sample3.rb2 \
sample1.tst sample2.tst sample3.tst
-
--blocksort.o: blocksort.c
++
+blocksort.so: blocksort.c
- @cat words0
++ @cat words0
+ $(CC) $(CFLAGS) $(SOFLAGS) -c blocksort.c -o blocksort.so
+huffman.so: huffman.c
+ $(CC) $(CFLAGS) $(SOFLAGS) -c huffman.c -o huffman.so
@@ -71,8 +76,6 @@
+ $(CC) $(CFLAGS) $(SOFLAGS) -c decompress.c -o decompress.so
+bzlib.so: bzlib.c
+ $(CC) $(CFLAGS) $(SOFLAGS) -c bzlib.c -o bzlib.so
-+
-+blocksort.o: blocksort.c
- $(CC) $(CFLAGS) -c blocksort.c
- huffman.o: huffman.c
- $(CC) $(CFLAGS) -c huffman.c
+
+ blocksort.o: blocksort.c
+ @cat words0
diff --git a/archivers/bzip2/pkg-descr b/archivers/bzip2/pkg-descr
index 882e45585216..da3f03594b3b 100644
--- a/archivers/bzip2/pkg-descr
+++ b/archivers/bzip2/pkg-descr
@@ -1,4 +1,4 @@
This is bzip2, a advanced block-sorting file compressor. It is
believed to be free from any patents.
-WWW: http://sourceware.cygnus.com/bzip2/
+WWW: http://sources.redhat.com/bzip2/
diff --git a/archivers/bzip2/pkg-plist b/archivers/bzip2/pkg-plist
index a737af9530fc..d8dfe5510cfc 100644
--- a/archivers/bzip2/pkg-plist
+++ b/archivers/bzip2/pkg-plist
@@ -4,6 +4,11 @@ bin/bunzip2
bin/bzcat
bin/bz2cat
bin/bzip2recover
+bin/bzgrep
+bin/bzegrep
+bin/bzfgrep
+bin/bzmore
+bin/bzless
include/bzlib.h
lib/libbz2.a
lib/libbz2.so
@@ -15,4 +20,9 @@ lib/libbz2.so.1
%%PORTDOCS%%share/doc/bzip2/manual_3.html
%%PORTDOCS%%share/doc/bzip2/manual_4.html
%%PORTDOCS%%share/doc/bzip2/manual_toc.html
+%%PORTDOCS%%share/doc/bzip2/manual.html
+%%PORTDOCS%%share/doc/bzip2/manual_abt.html
+%%PORTDOCS%%share/doc/bzip2/manual_ovr.html
+%%PORTDOCS%%share/doc/bzip2/manual.pdf
+%%PORTDOCS%%share/doc/bzip2/bzip2.txt
%%PORTDOCS%%@dirrm share/doc/bzip2