aboutsummaryrefslogtreecommitdiff
path: root/archivers/dact
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-03-24 23:17:20 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-03-24 23:17:20 +0000
commit362d680e01ad265efb36d93f7bdb577b3044764a (patch)
treeee345b56d8d4997b2a43e522cda05037e1299071 /archivers/dact
parent7890b491814462e7f8d8595e4ff369b7363e9d4a (diff)
downloadports-362d680e01ad265efb36d93f7bdb577b3044764a.tar.gz
ports-362d680e01ad265efb36d93f7bdb577b3044764a.zip
Support stage
Notes
Notes: svn path=/head/; revision=349093
Diffstat (limited to 'archivers/dact')
-rw-r--r--archivers/dact/Makefile27
-rw-r--r--archivers/dact/files/patch-Makefile.in13
-rw-r--r--archivers/dact/pkg-plist1
3 files changed, 20 insertions, 21 deletions
diff --git a/archivers/dact/Makefile b/archivers/dact/Makefile
index 625ec282728b..9f407722ccd2 100644
--- a/archivers/dact/Makefile
+++ b/archivers/dact/Makefile
@@ -12,37 +12,22 @@ COMMENT= Dynamic Adaptive Compression Tool
LIB_DEPENDS= libmcrypt.so:${PORTSDIR}/security/libmcrypt \
liblzo2.so:${PORTSDIR}/archivers/lzo2
-NO_STAGE= yes
-USES= gmake
+USES= gmake desthack
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --libdir=${PREFIX}/lib
CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ARGS= TOBUILD="dact libdact.so dact.conf"
-MAN1= dact.1
USE_LDCONFIG= yes
OPTIONS_DEFINE= DOCS EXAMPLES
-.include <bsd.port.options.mk>
-post-patch:
- @${REINPLACE_CMD} -e "s|prefix = @prefix@|prefix = ${PREFIX}|" \
- -e "s|libdir = @libdir@|libdir = ${PREFIX}/lib|" \
- ${WRKSRC}/Makefile.in
-
-pre-install:
- @${RM} -f ${WRKSRC}/libdact.a
-
post-install:
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- ${CP} -n ${WRKSRC}/dact.conf ${EXAMPLESDIR} || ${TRUE}
-.endif
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/Docs/dact.txt ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/dact.conf ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Docs/dact.txt ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/archivers/dact/files/patch-Makefile.in b/archivers/dact/files/patch-Makefile.in
new file mode 100644
index 000000000000..a4351eb0e325
--- /dev/null
+++ b/archivers/dact/files/patch-Makefile.in
@@ -0,0 +1,13 @@
+--- ./Makefile.in.orig 2006-03-25 14:15:04.000000000 +0100
++++ ./Makefile.in 2014-03-25 00:16:17.000000000 +0100
+@@ -24,8 +24,8 @@
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+-libdir = @libdir@
+-bindir = @bindir@
++libdir = @prefix@/lib
++bindir = @prefix@/bin
+ sysconfdir = @sysconfdir@
+ mandir = @mandir@
+ datadir = @datadir@
diff --git a/archivers/dact/pkg-plist b/archivers/dact/pkg-plist
index 12c230f682bd..474f00c24806 100644
--- a/archivers/dact/pkg-plist
+++ b/archivers/dact/pkg-plist
@@ -1,6 +1,7 @@
bin/dact
etc/dact.conf
lib/libdact.so
+man/man1/dact.1.gz
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/dact.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dact.conf