aboutsummaryrefslogtreecommitdiff
path: root/archivers/deutex
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2012-02-12 09:09:18 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2012-02-12 09:09:18 +0000
commit0d24562615cd32fbcde869a683a5aa1eea15d252 (patch)
tree4f59c7305ac9d9eaf81a28533c00887022f1837a /archivers/deutex
parentf263495e15759514439ee11c6b79dc082ab2f020 (diff)
downloadports-0d24562615cd32fbcde869a683a5aa1eea15d252.tar.gz
ports-0d24562615cd32fbcde869a683a5aa1eea15d252.zip
- Fix bad work with data types between architectures which resulted in
immediate segfault when being run on e.g. amd64 - Fix wrong length when reading block into structure (probably a typo) - Other minor non-functional fixes PR: ports/161664 Submitted by: Cray Elliott
Notes
Notes: svn path=/head/; revision=291025
Diffstat (limited to 'archivers/deutex')
-rw-r--r--archivers/deutex/Makefile4
-rw-r--r--archivers/deutex/files/patch-src-deutex.h33
2 files changed, 37 insertions, 0 deletions
diff --git a/archivers/deutex/Makefile b/archivers/deutex/Makefile
index 9529b2acd513..faf9fed3192b 100644
--- a/archivers/deutex/Makefile
+++ b/archivers/deutex/Makefile
@@ -7,6 +7,7 @@
PORTNAME= deutex
PORTVERSION= 4.4.0
+PORTREVISION= 1
CATEGORIES= archivers games
MASTER_SITES= http://www.teaser.fr/~amajorel/deutex/ \
http://freebsd.nsu.ru/distfiles/
@@ -23,7 +24,10 @@ PLIST_FILES= bin/deusf bin/deutex
PORTDOCS= *
post-extract:
+ @${REINPLACE_CMD} -e 's,-mkdir,mkdir -p,' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's,malloc\.h,stdlib.h,' ${WRKSRC}/src/tools.c
+ @${REINPLACE_CMD} -e '/blockv/s,VOCHEAD,VOCBLOCK1,' \
+ ${WRKSRC}/src/sound.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/deusf ${WRKSRC}/deutex ${PREFIX}/bin
diff --git a/archivers/deutex/files/patch-src-deutex.h b/archivers/deutex/files/patch-src-deutex.h
new file mode 100644
index 000000000000..20e713558adb
--- /dev/null
+++ b/archivers/deutex/files/patch-src-deutex.h
@@ -0,0 +1,33 @@
+--- src/deutex.h.orig 1999-12-31 07:20:22.000000000 +0800
++++ src/deutex.h 2012-02-12 16:53:51.000000000 +0800
+@@ -31,23 +31,13 @@
+ #define DeuSF for DOS .EXE Unix Linux OS/2
+ *********************************************/
+
+-#if defined (__alpha) /*__ALPHA__ for Alpha processor?*/
+-/*long = int64 on a 64bit processor*/
+-typedef char Int8;
+-typedef short Int16;
+-typedef int Int32;
+-typedef unsigned char UInt8;
+-typedef unsigned short UInt16;
+-typedef unsigned int UInt32;
+-#else
+-/*long = Int32 on a 32 bit processor*/
+-typedef char Int8;
+-typedef short Int16;
+-typedef long Int32;
+-typedef unsigned char UInt8;
+-typedef unsigned short UInt16;
+-typedef unsigned long UInt32;
+-#endif
++#include <stdint.h>
++typedef int8_t Int8;
++typedef int16_t Int16;
++typedef int32_t Int32;
++typedef uint8_t UInt8;
++typedef uint16_t UInt16;
++typedef uint32_t UInt32;
+
+ #if defined DeuTex
+ #if defined DeuSF