aboutsummaryrefslogtreecommitdiff
path: root/archivers/deutex
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-08-09 13:02:31 +0000
committerKai Knoblich <kai@FreeBSD.org>2019-08-09 13:02:31 +0000
commit52f35390899117d19c2c8d8956c95537f618a717 (patch)
tree1f4cc387cb97739745f43a9e8cc5e5566a1c185f /archivers/deutex
parentcdbddd45831dcfe26a74c3f55bc6441247be1a66 (diff)
downloadports-52f35390899117d19c2c8d8956c95537f618a717.tar.gz
ports-52f35390899117d19c2c8d8956c95537f618a717.zip
archivers/deutex: Update to 5.2.0 and unbreak
After many years of being dormant upstream has continued the development, moved to GitHub and modernized the whole code base. * Remove the patch for deutex.h that is no longer required. [1] * Also take maintainership for a while. Notable changes since the 4.4.0 release: * Removed DeuSF binary and WinTex related features/options. * PNG support added. If compiled in, it is the default extraction format, PPM otherwise. * DeuTex can now build WADs with an arbitrary number of lumps, but prints a warning when more than 4046 are included (the Vanilla Doom limit). * UDMF (Universal Doom Map Format) support. * Real Autoconf and Automake build system to replace the barely-functioning imitation one. * C99-style cleanups to use (u)intN_t types, bool, true, false throughout the code, replacing old defines. [1] https://github.com/Doom-Utils/deutex/releases/tag/v5.2.0 https://github.com/Doom-Utils/deutex/releases/tag/v5.1.0 https://github.com/Doom-Utils/deutex/releases/tag/v5.0.0
Notes
Notes: svn path=/head/; revision=508451
Diffstat (limited to 'archivers/deutex')
-rw-r--r--archivers/deutex/Makefile36
-rw-r--r--archivers/deutex/distinfo5
-rw-r--r--archivers/deutex/files/patch-src_deutex.h33
3 files changed, 17 insertions, 57 deletions
diff --git a/archivers/deutex/Makefile b/archivers/deutex/Makefile
index 046740412c51..dcf3f13185b4 100644
--- a/archivers/deutex/Makefile
+++ b/archivers/deutex/Makefile
@@ -2,13 +2,11 @@
# $FreeBSD$
PORTNAME= deutex
-PORTVERSION= 4.4.0
-PORTREVISION= 1
+PORTVERSION= 5.2.0
+DISTVERSIONPREFIX= v
CATEGORIES= archivers games
-MASTER_SITES= http://www.teaser.fr/~amajorel/deutex/ \
- http://freebsd.nsu.ru/distfiles/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= kai@FreeBSD.org
COMMENT= WAD file manipulator for Doom, Heretic, Hexen, and Strife
LICENSE= GPLv2 LGPL20 MIT
@@ -16,31 +14,25 @@ LICENSE_COMB= multi
LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING
LICENSE_FILE_LGPL20= ${WRKSRC}/COPYING.LIB
-BROKEN= unfetchable
+BUILD_DEPENDS= a2x:textproc/asciidoc
-MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
+USES= autoreconf pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= Doom-Utils
-PLIST_FILES= bin/deusf bin/deutex \
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/deutex \
man/man6/${PORTNAME}.6.gz
PORTDOCS= *
-OPTIONS_DEFINE= DOCS
-
-post-extract:
- @${REINPLACE_CMD} -e 's,-mkdir,mkdir -p,' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's,malloc\.h,stdlib.h,' ${WRKSRC}/src/tools.c
- @${REINPLACE_CMD} -e '/blockv/s,VOCHEAD,VOCBLOCK1,' \
- ${WRKSRC}/src/sound.c
+OPTIONS_DEFINE= DOCS PNG
+OPTIONS_DEFAULT= PNG
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/deusf ${WRKSRC}/deutex \
- ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.6 \
- ${STAGEDIR}${MAN6PREFIX}/man/man6
+PNG_LIB_DEPENDS= libpng.so:graphics/png
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/CHANGES ${WRKSRC}/TODO ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/dtexman6.txt ${STAGEDIR}${DOCSDIR}/MANUAL
+ ${INSTALL_MAN} ${WRKSRC}/NEWS.adoc ${WRKSRC}/README.adoc ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/archivers/deutex/distinfo b/archivers/deutex/distinfo
index 3e7381a8adff..f2c3b8c0d46a 100644
--- a/archivers/deutex/distinfo
+++ b/archivers/deutex/distinfo
@@ -1,2 +1,3 @@
-SHA256 (deutex-4.4.0.tar.gz) = e87ff2984c6555f30408ee7aa4e6461aac6f1d3d0a1e21b4e12a797a057ba3b7
-SIZE (deutex-4.4.0.tar.gz) = 215945
+TIMESTAMP = 1565106114
+SHA256 (Doom-Utils-deutex-v5.2.0_GH0.tar.gz) = a53928d2af4dec88da4a644384766cfc94512cc8531ff9fcbaaf7012dd6de56d
+SIZE (Doom-Utils-deutex-v5.2.0_GH0.tar.gz) = 124341
diff --git a/archivers/deutex/files/patch-src_deutex.h b/archivers/deutex/files/patch-src_deutex.h
deleted file mode 100644
index e410fcd1e6ed..000000000000
--- a/archivers/deutex/files/patch-src_deutex.h
+++ /dev/null
@@ -1,33 +0,0 @@
---- src/deutex.h.orig 1999-12-30 23:20:22 UTC
-+++ src/deutex.h
-@@ -31,23 +31,13 @@ Place, Suite 330, Boston, MA 02111-1307,
- #define DeuSF for DOS .EXE Unix Linux OS/2
- *********************************************/
-
--#if defined (__alpha) /*__ALPHA__ for Alpha processor?*/
--/*long = int64 on a 64bit processor*/
--typedef char Int8;
--typedef short Int16;
--typedef int Int32;
--typedef unsigned char UInt8;
--typedef unsigned short UInt16;
--typedef unsigned int UInt32;
--#else
--/*long = Int32 on a 32 bit processor*/
--typedef char Int8;
--typedef short Int16;
--typedef long Int32;
--typedef unsigned char UInt8;
--typedef unsigned short UInt16;
--typedef unsigned long UInt32;
--#endif
-+#include <stdint.h>
-+typedef int8_t Int8;
-+typedef int16_t Int16;
-+typedef int32_t Int32;
-+typedef uint8_t UInt8;
-+typedef uint16_t UInt16;
-+typedef uint32_t UInt32;
-
- #if defined DeuTex
- #if defined DeuSF