aboutsummaryrefslogtreecommitdiff
path: root/archivers/dzip
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-02-08 10:34:21 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-02-08 10:34:21 +0000
commitbf66aa0aae6fca1c524bbd14e86616bb51563893 (patch)
tree81b05521d22b84d8c71cd36a876e7a00c7065885 /archivers/dzip
parent6044e309e5430c20265dcd313bcb5dd18d83cfdd (diff)
downloadports-bf66aa0aae6fca1c524bbd14e86616bb51563893.tar.gz
ports-bf66aa0aae6fca1c524bbd14e86616bb51563893.zip
- Install `Readme' file as documentation
- Reclaim maintainership while I'm at it
Notes
Notes: svn path=/head/; revision=525544
Diffstat (limited to 'archivers/dzip')
-rw-r--r--archivers/dzip/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/archivers/dzip/Makefile b/archivers/dzip/Makefile
index fe9782eaf2a2..2523ce38233b 100644
--- a/archivers/dzip/Makefile
+++ b/archivers/dzip/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= archivers games
MASTER_SITES= http://speeddemosarchive.com/dzip/
DISTNAME= dz${PORTVERSION:S/.//g}src
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= File compression utility specializing in Quake demo compression
LICENSE= ZLIB
@@ -20,6 +20,9 @@ MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
ALL_TARGET= ${PORTNAME}
PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= Readme
+
+OPTIONS_DEFINE= DOCS
post-extract: .SILENT
${REINPLACE_CMD} -e 's/ifdef BIG_ENDIAN/if BYTE_ORDER == BIG_ENDIAN/' \
@@ -32,4 +35,8 @@ post-extract: .SILENT
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}/${PREFIX}/bin
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>