aboutsummaryrefslogtreecommitdiff
path: root/archivers/fastjar
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2017-02-13 16:52:44 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2017-02-13 16:52:44 +0000
commitcb09e3fa692b636d7d0cab78a8bae1fa750437ff (patch)
treeef30ff59ca08380dbad8427ca9feb97570cda29e /archivers/fastjar
parent59e46d969a2acccf64b03ca1c0d537efa67cc6e4 (diff)
downloadports-cb09e3fa692b636d7d0cab78a8bae1fa750437ff.tar.gz
ports-cb09e3fa692b636d7d0cab78a8bae1fa750437ff.zip
Remove -fPIC and fix the real problem where end_of_entries is sometimes
declared as unsigned int and sometimes as off_t which have a different size and alignment.
Notes
Notes: svn path=/head/; revision=434003
Diffstat (limited to 'archivers/fastjar')
-rw-r--r--archivers/fastjar/Makefile3
-rw-r--r--archivers/fastjar/files/patch-jartool.c11
2 files changed, 12 insertions, 2 deletions
diff --git a/archivers/fastjar/Makefile b/archivers/fastjar/Makefile
index 146609add818..1f1131478021 100644
--- a/archivers/fastjar/Makefile
+++ b/archivers/fastjar/Makefile
@@ -3,6 +3,7 @@
PORTNAME= fastjar
PORTVERSION= 0.93.20060808
+PORTREVISION= 1
CATEGORIES= archivers java
MASTER_SITES= LOCAL/maho/fastjar
@@ -15,8 +16,6 @@ USES= gmake makeinfo perl5 tar:bzip2
USES_PERL5= build
GNU_CONFIGURE= yes
-CFLAGS_aarch64= -fPIC
-
WRKSRC= ${WRKDIR}/${PORTNAME}
PORTDOCS= CHANGES ChangeLog NEWS README
PLIST_FILES= bin/fastjar bin/grepjar \
diff --git a/archivers/fastjar/files/patch-jartool.c b/archivers/fastjar/files/patch-jartool.c
new file mode 100644
index 000000000000..001fb358468b
--- /dev/null
+++ b/archivers/fastjar/files/patch-jartool.c
@@ -0,0 +1,11 @@
+--- jartool.c.orig 2006-08-07 08:06:23 UTC
++++ jartool.c
+@@ -313,7 +313,7 @@ int number_of_entries; /* number of entr
+ const char *progname;
+
+ /* The offset of the end of the last zip entry. */
+-ub4 end_of_entries;
++off_t end_of_entries;
+
+ /* This is used to mark options with no short value. */
+ #define LONG_OPT(Num) ((Num) + 128)