aboutsummaryrefslogtreecommitdiff
path: root/archivers/ha
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>1995-01-24 16:43:33 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>1995-01-24 16:43:33 +0000
commitc209ef1e9b68900e8dcbca16b62e6f17de9dd6fe (patch)
tree1dc7b317431f85ad549cd995f7e6bb3375bbda26 /archivers/ha
parente1f99584be6ed18a5e606ac25d3aea85d6e0d160 (diff)
downloadports-c209ef1e9b68900e8dcbca16b62e6f17de9dd6fe.tar.gz
ports-c209ef1e9b68900e8dcbca16b62e6f17de9dd6fe.zip
HA archiver
Notes
Notes: svn path=/head/; revision=818
Diffstat (limited to 'archivers/ha')
-rw-r--r--archivers/ha/Makefile20
-rw-r--r--archivers/ha/distinfo1
-rw-r--r--archivers/ha/files/patch-aa19
3 files changed, 40 insertions, 0 deletions
diff --git a/archivers/ha/Makefile b/archivers/ha/Makefile
new file mode 100644
index 000000000000..f55ff247e6ba
--- /dev/null
+++ b/archivers/ha/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: ha
+# Version required: 0999
+# Date created: 24 Jan 1995
+# Whom: ache
+#
+# $Id: Makefile,v 1.1.1.1 1994/12/28 15:19:16 ache Exp $
+#
+DISTNAME= ha0999
+EXTRACT_SUFX= .tgz
+MASTER_SITES= ftp://ftp.kiae.su/unix/arcers/
+NO_WRKSUBDIR= YES
+MAKEFILE= makefile.nix
+MAKE_FLAGS= CC=cc -f
+ALL_TARGET= ha
+USE_GMAKE= YES
+
+install:
+ cd ${WRKSRC}; ${INSTALL} ${COPY} ${STRIP} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} ha ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/archivers/ha/distinfo b/archivers/ha/distinfo
new file mode 100644
index 000000000000..f3b341df4e25
--- /dev/null
+++ b/archivers/ha/distinfo
@@ -0,0 +1 @@
+MD5 (ha0999.tgz) = 77f3266a451712bec55d60df67f61486
diff --git a/archivers/ha/files/patch-aa b/archivers/ha/files/patch-aa
new file mode 100644
index 000000000000..0bdd3610fb1a
--- /dev/null
+++ b/archivers/ha/files/patch-aa
@@ -0,0 +1,19 @@
+*** nix/machine.c.bak Thu Jan 12 09:53:00 1995
+--- nix/machine.c Tue Jan 24 19:38:07 1995
+***************
+*** 417,423 ****
+ if (plainname!=NULL) free(plainname),plainname=NULL;
+ if ((plainname=malloc(strlen(mdfullpath)+1))==NULL)
+ error(1,ERR_MEM,"md_stripname()");
+! for (i=strlen(mdfullpath)-1;i>0;i--) {
+ if (mdfullpath[i]=='/') {
+ i++;
+ break;
+--- 417,423 ----
+ if (plainname!=NULL) free(plainname),plainname=NULL;
+ if ((plainname=malloc(strlen(mdfullpath)+1))==NULL)
+ error(1,ERR_MEM,"md_stripname()");
+! for (i=strlen(mdfullpath)-1;i>=0;i--) {
+ if (mdfullpath[i]=='/') {
+ i++;
+ break;