aboutsummaryrefslogtreecommitdiff
path: root/archivers/ha
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2006-08-12 13:46:06 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2006-08-12 13:46:06 +0000
commite309a114ea4106459515f19abda536e4f982875e (patch)
tree13ab4497c647a07c0415e21b3fce2fe1d9b9c680 /archivers/ha
parentae3747243cca886d9118bcc15c42e97f89088151 (diff)
downloadports-e309a114ea4106459515f19abda536e4f982875e.tar.gz
ports-e309a114ea4106459515f19abda536e4f982875e.zip
- Respect DESTDIR
- Eliminate a patch - Use INSTALL_PROGRAM to install the binary PR: 101918 Submitted by: gabor
Notes
Notes: svn path=/head/; revision=170413
Diffstat (limited to 'archivers/ha')
-rw-r--r--archivers/ha/Makefile10
-rw-r--r--archivers/ha/files/patch-ab15
2 files changed, 7 insertions, 18 deletions
diff --git a/archivers/ha/Makefile b/archivers/ha/Makefile
index f0dc61efba1e..70c428984c6e 100644
--- a/archivers/ha/Makefile
+++ b/archivers/ha/Makefile
@@ -22,12 +22,16 @@ MAKEFILE= makefile.nix
ALL_TARGET= ha
USE_GMAKE= yes
-pre-patch:
- @${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>,' \
+post-patch:
+ @${REINPLACE_CMD} 's,<malloc.h>,<stdlib.h>,' \
${WRKSRC}/c/hsc.c ${WRKSRC}/c/cpy.c \
${WRKSRC}/c/asc.c
+ @${REINPLACE_CMD} -e 's|CC =|CC ?=|' \
+ -e 's|LDFLAGS = -O2||' \
+ -e 's|CFLAGS = -Wall -O2|CFLAGS += -Wall|' \
+ ${WRKSRC}/makefile.nix
do-install:
- cd ${WRKSRC}; ${INSTALL} ${COPY} ${STRIP} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} ha ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/ha ${TARGETDIR}/bin
.include <bsd.port.mk>
diff --git a/archivers/ha/files/patch-ab b/archivers/ha/files/patch-ab
deleted file mode 100644
index 65be1d557ba1..000000000000
--- a/archivers/ha/files/patch-ab
+++ /dev/null
@@ -1,15 +0,0 @@
---- makefile.nix.orig Wed Jan 11 23:26:26 1995
-+++ makefile.nix Sat Mar 30 18:39:08 2002
-@@ -21,10 +21,9 @@
-
- MCH = nix
-
--CC = gcc
-+CC ?= gcc
- CPP = $(CC) -E
--CFLAGS = -Wall -O2 -c -I../$(MCH) -I../include
--LDFLAGS = -O2
-+CFLAGS += -Wall -c -I../$(MCH) -I../include
-
- MDEFINES = "CC=$(CC)" "CPP=$(CPP)" "CFLAGS=$(CFLAGS)" "DEFS=$(DEFS)"
- SUBDIRS = c $(MCH) include