aboutsummaryrefslogtreecommitdiff
path: root/archivers/hlextract
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2013-02-14 22:05:15 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2013-02-14 22:05:15 +0000
commitd34a2648596be33afeef66387a2e867c7686b0ed (patch)
tree9f4bd07040aeb53ce64245ff5f6f1ebdab4084e4 /archivers/hlextract
parent13f09390a9da3044847a2f99e45c335dfa39fb5b (diff)
downloadports-d34a2648596be33afeef66387a2e867c7686b0ed.tar.gz
ports-d34a2648596be33afeef66387a2e867c7686b0ed.zip
- Update to 2.4.4
- Pass maintainership to submitter - Make CLANG happy PR: ports/176042 Submitted by: Danilo Egea Gondolfo <danilogondolfo@gmail.com>
Notes
Notes: svn path=/head/; revision=312245
Diffstat (limited to 'archivers/hlextract')
-rw-r--r--archivers/hlextract/Makefile11
-rw-r--r--archivers/hlextract/distinfo4
-rw-r--r--archivers/hlextract/files/patch-HLExtract-Main.c82
3 files changed, 89 insertions, 8 deletions
diff --git a/archivers/hlextract/Makefile b/archivers/hlextract/Makefile
index a4501cd88b68..74c6398682b5 100644
--- a/archivers/hlextract/Makefile
+++ b/archivers/hlextract/Makefile
@@ -2,26 +2,25 @@
# $FreeBSD$
PORTNAME= hlextract
-PORTVERSION= 2.4.3
+PORTVERSION= 2.4.4
CATEGORIES= archivers games
MASTER_SITES= http://nemesis.thewavelength.net/files/files/
DISTNAME= hllib${PORTVERSION:S/.//g}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danilogondolfo@gmail.com
COMMENT= Utility to extract data from various Half-Life file formats
LICENSE= GPLv2
LIB_DEPENDS= hl:${PORTSDIR}/games/hllib
+USE_DOS2UNIX= yes
USE_ZIP= yes
WRKSRC= ${WRKDIR}/HLExtract
-PLIST_FILES= bin/${PORTNAME}
+PATCH_WRKSRC= ${WRKDIR}
-post-patch:
- @${REINPLACE_CMD} -e 's,linux/limits,sys/param, ; \
- s,HLExtract\.exe,${PORTNAME},' ${WRKSRC}/Main.c
+PLIST_FILES= bin/${PORTNAME}
do-build:
${CC} ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib \
diff --git a/archivers/hlextract/distinfo b/archivers/hlextract/distinfo
index f855201d7d04..2aec4971ab18 100644
--- a/archivers/hlextract/distinfo
+++ b/archivers/hlextract/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hllib243.zip) = 2eafa706ab4cccea0c9966f45e5eabf4bad27b5b4b224cc6592ba68debd54ae0
-SIZE (hllib243.zip) = 591480
+SHA256 (hllib244.zip) = cb94da1c32e9577dce1aa2bbb77f283212684afcd7814d42228c9ffff71d3699
+SIZE (hllib244.zip) = 593745
diff --git a/archivers/hlextract/files/patch-HLExtract-Main.c b/archivers/hlextract/files/patch-HLExtract-Main.c
new file mode 100644
index 000000000000..c278a81f2bd8
--- /dev/null
+++ b/archivers/hlextract/files/patch-HLExtract-Main.c
@@ -0,0 +1,82 @@
+diff -ru ../orig/HLExtract/Main.c ./HLExtract/Main.c
+--- ../orig/HLExtract/Main.c 2011-09-17 00:41:54.000000000 -0300
++++ ./HLExtract/Main.c 2013-02-11 18:29:02.880217165 -0200
+@@ -52,7 +52,7 @@
+ # define WIN32_LEAN_AND_MEAN
+ # include <windows.h>
+ #else
+-# include <linux/limits.h>
++# include <sys/param.h>
+ # define MAX_PATH PATH_MAX
+
+ # define FOREGROUND_BLUE 0x0001
+@@ -618,15 +618,15 @@
+ printf("\n");
+ printf("Example HLExtract usage:\n");
+ #ifdef _WIN32
+- printf("HLExtract.exe -p \"C:\\half-life.gcf\" -d \"C:\\backup\" -e \"root\\valve\\models\" -e \"root\\valve\\config.cfg\"\n");
+- printf("HLExtract.exe -p \"C:\\half-life.gcf\" -c -m -v\n");
+- printf("HLExtract.exe -p \"C:\\half-life.gcf\" -lf \"C:\\half-life.txt\" -m -s\n");
+- printf("HLExtract.exe -p \"C:\\half-life.gcf\" -m -f\n");
++ printf("hlextract -p \"C:\\half-life.gcf\" -d \"C:\\backup\" -e \"root\\valve\\models\" -e \"root\\valve\\config.cfg\"\n");
++ printf("hlextract -p \"C:\\half-life.gcf\" -c -m -v\n");
++ printf("hlextract -p \"C:\\half-life.gcf\" -lf \"C:\\half-life.txt\" -m -s\n");
++ printf("hlextract -p \"C:\\half-life.gcf\" -m -f\n");
+ #else
+- printf("HLExtract.exe -p \"~/half-life.gcf\" -d \"~/backup\" -e \"root/valve/models\" -e \"root/valve/config.cfg\"\n");
+- printf("HLExtract.exe -p \"~/half-life.gcf\" -c -m -v\n");
+- printf("HLExtract.exe -p \"~/half-life.gcf\" -lf \"~/half-life.txt\" -m -s\n");
+- printf("HLExtract.exe -p \"~/half-life.gcf\" -m -f\n");
++ printf("hlextract -p \"~/half-life.gcf\" -d \"~/backup\" -e \"root/valve/models\" -e \"root/valve/config.cfg\"\n");
++ printf("hlextract -p \"~/half-life.gcf\" -c -m -v\n");
++ printf("hlextract -p \"~/half-life.gcf\" -lf \"~/half-life.txt\" -m -s\n");
++ printf("hlextract -p \"~/half-life.gcf\" -m -f\n");
+ #endif
+ }
+
+@@ -657,6 +657,8 @@
+ fprintf(pFile, "%s\n", lpPath);
+ }
+ break;
++ default:
++ ;
+ }
+ }
+
+@@ -843,6 +845,8 @@
+ PrintValidation(eValidation);
+ printf("\n");
+ break;
++ default:
++ ;
+ }
+ }
+ else
+@@ -851,6 +855,8 @@
+ printf(" \n");
+ }
+ break;
++ default:
++ ;
+ }
+
+ return eValidation;
+@@ -882,6 +888,8 @@
+ case HL_ATTRIBUTE_STRING:
+ printf("%s%s: %s%s\n", lpPrefix, pAttribute->lpName, pAttribute->Value.String.lpValue, lpPostfix);
+ break;
++ default:
++ ;
+ }
+ }
+
+@@ -1151,6 +1159,8 @@
+ printf(" Size: %u B\n", hlFileGetSize(pSubItem));
+ printf(" Size On Disk: %u B\n", hlFileGetSizeOnDisk(pSubItem));
+ break;
++ default:
++ ;
+ }
+
+ uiItemCount = hlPackageGetItemAttributeCount();
+Only in ./HLExtract: Main.c.bak