aboutsummaryrefslogtreecommitdiff
path: root/archivers/libcabinet
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-04-22 14:34:15 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-04-22 14:34:15 +0000
commitc4b5ad32e8d3e09eaa11fda8ab6aef2df38c90ec (patch)
tree2466af504f3d26590ac318e6c1e36bd1c0f20c5d /archivers/libcabinet
parentd30cd9e1c1b793f213d03b066d505c372a533da6 (diff)
downloadports-c4b5ad32e8d3e09eaa11fda8ab6aef2df38c90ec.tar.gz
ports-c4b5ad32e8d3e09eaa11fda8ab6aef2df38c90ec.zip
archivers/libcabinet: Unbreak build on recent CURRENT
c++ -O2 -pipe -fstack-protector -fno-strict-aliasing -Wno-deprecated -std=c++11 -Wno-c++11-extensions -c bstring.cpp -o bstring.o In file included from bstring.cpp:16: ./bstring.h:59:40: error: use of undeclared identifier 'strlwr'; did you mean 'strlen'? b_string& StrLwr() { if(str != NULL) strlwr(str); return *this; } ^~~~~~ strlen http://beefy12.nyi.freebsd.org/data/head-amd64-default/p499421_s346424/logs/errors/libcabinet-0.30_2.log This is caused by having a CXXSTD with default value of c++11 in bsd.sys.mk now. Set CXXSTD to gnu++98 explicitly.
Notes
Notes: svn path=/head/; revision=499648
Diffstat (limited to 'archivers/libcabinet')
-rw-r--r--archivers/libcabinet/files/patch-Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/archivers/libcabinet/files/patch-Makefile b/archivers/libcabinet/files/patch-Makefile
index cdf7152ad4fc..a22f38821307 100644
--- a/archivers/libcabinet/files/patch-Makefile
+++ b/archivers/libcabinet/files/patch-Makefile
@@ -1,8 +1,9 @@
---- Makefile.orig 2016-07-26 12:03:27 UTC
+--- Makefile.orig 2019-04-22 14:24:18 UTC
+++ Makefile
-@@ -0,0 +1,16 @@
+@@ -0,0 +1,17 @@
+NO_PROFILE= true
-+CXXFLAGS+= -Wno-deprecated
++CXXFLAGS+= -Wno-deprecated
++CXXSTD= gnu++98
+LIB= cabinet
+LIBDIR= ${PREFIX}/lib
+INCSDIR= ${PREFIX}/include/cabinet