aboutsummaryrefslogtreecommitdiff
path: root/archivers/libunrar
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-06-07 18:14:05 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-06-07 18:14:05 +0000
commitadd037db1bc6214b34700f987ac39b8d4c96b18e (patch)
tree6a496efb7260764b2cf14717f50b894037e241ee /archivers/libunrar
parent47f58e562edb30b3a5b19d2e744318df51dc2877 (diff)
downloadports-add037db1bc6214b34700f987ac39b8d4c96b18e.tar.gz
ports-add037db1bc6214b34700f987ac39b8d4c96b18e.zip
- Update to 3.60.b4
PR: ports/98612 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=164734
Diffstat (limited to 'archivers/libunrar')
-rw-r--r--archivers/libunrar/Makefile5
-rw-r--r--archivers/libunrar/distinfo6
-rw-r--r--archivers/libunrar/files/patch-extract.cpp10
3 files changed, 15 insertions, 6 deletions
diff --git a/archivers/libunrar/Makefile b/archivers/libunrar/Makefile
index 44204c4118a4..e7ae37a13ebf 100644
--- a/archivers/libunrar/Makefile
+++ b/archivers/libunrar/Makefile
@@ -6,15 +6,14 @@
#
PORTNAME= libunrar
-PORTVERSION= 3.54
-PORTREVISION= 1
+PORTVERSION= 3.60.b4
CATEGORIES= archivers
MASTER_SITES= http://files2.rarlab.com/rar/ \
http://files3.rarlab.com/rar/ \
http://files4.rarlab.com/rar/ \
http://files5.rarlab.com/rar/ \
http://files6.rarlab.com/rar/
-DISTNAME= unrarsrc-3.5.4
+DISTNAME= unrarsrc-3.6.4
MAINTAINER= samm@os2.kiev.ua
COMMENT= Library to work with RAR archivies
diff --git a/archivers/libunrar/distinfo b/archivers/libunrar/distinfo
index cd7232800414..596a41ffbc7f 100644
--- a/archivers/libunrar/distinfo
+++ b/archivers/libunrar/distinfo
@@ -1,3 +1,3 @@
-MD5 (unrarsrc-3.5.4.tar.gz) = 3c3901173888e08dac22fca8a93ec5e6
-SHA256 (unrarsrc-3.5.4.tar.gz) = caf75266a359456398b0bbfa4ea9c1c2d3fcc9088bfe6a1309bf51e3d5376989
-SIZE (unrarsrc-3.5.4.tar.gz) = 122801
+MD5 (unrarsrc-3.6.4.tar.gz) = 001602097819fdbe6aa3cf46af01d922
+SHA256 (unrarsrc-3.6.4.tar.gz) = 625611fda1baec14f4fedffc2b8b8997caf6f3f360d843f6c1304a508a297e4a
+SIZE (unrarsrc-3.6.4.tar.gz) = 124913
diff --git a/archivers/libunrar/files/patch-extract.cpp b/archivers/libunrar/files/patch-extract.cpp
new file mode 100644
index 000000000000..5be2fcfa6ec0
--- /dev/null
+++ b/archivers/libunrar/files/patch-extract.cpp
@@ -0,0 +1,10 @@
+--- extract.cpp.orig Wed Jun 7 08:52:35 2006
++++ extract.cpp Wed Jun 7 08:55:35 2006
+@@ -291,6 +291,7 @@
+ char CurVolName[NM];
+ strcpy(CurVolName,ArcName);
+
++ if(strcmp(ArcName,"")==0) return(false);
+ VolNameToFirstName(ArcName,ArcName,(Arc.NewMhd.Flags & MHD_NEWNUMBERING));
+ if (stricomp(ArcName,CurVolName)!=0 && FileExist(ArcName))
+ {