aboutsummaryrefslogtreecommitdiff
path: root/archivers/libunrar
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-03-17 12:54:26 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-03-17 12:54:26 +0000
commitf27c11db127e15ce51aa99381686bf4abfa42fbc (patch)
treed02ce77776397dc9f680c2412da0162ee9ece2b4 /archivers/libunrar
parentb1e1535123895f6e96b1754589099d5289628f3d (diff)
downloadports-f27c11db127e15ce51aa99381686bf4abfa42fbc.tar.gz
ports-f27c11db127e15ce51aa99381686bf4abfa42fbc.zip
- Fix 100% cpu load
- Bump PORTREVISION PR: 94600 Submitted by: maintainer Thanks to: McMCC
Notes
Notes: svn path=/head/; revision=157491
Diffstat (limited to 'archivers/libunrar')
-rw-r--r--archivers/libunrar/Makefile1
-rw-r--r--archivers/libunrar/files/patch-dll.cpp16
2 files changed, 17 insertions, 0 deletions
diff --git a/archivers/libunrar/Makefile b/archivers/libunrar/Makefile
index 115259eef243..44204c4118a4 100644
--- a/archivers/libunrar/Makefile
+++ b/archivers/libunrar/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libunrar
PORTVERSION= 3.54
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= http://files2.rarlab.com/rar/ \
http://files3.rarlab.com/rar/ \
diff --git a/archivers/libunrar/files/patch-dll.cpp b/archivers/libunrar/files/patch-dll.cpp
new file mode 100644
index 000000000000..ace28c16309f
--- /dev/null
+++ b/archivers/libunrar/files/patch-dll.cpp
@@ -0,0 +1,16 @@
+diff -ruN unrar.orig/dll.cpp unrar/dll.cpp
+--- dll.cpp.orig 2005-08-03 20:34:30.000000000 +0400
++++ dll.cpp 2006-01-11 12:13:33.000000000 +0300
+@@ -271,8 +271,10 @@
+ strcpy(Data->Cmd.Command,Operation==RAR_EXTRACT ? "X":"T");
+ Data->Cmd.Test=Operation!=RAR_EXTRACT;
+ bool Repeat=false;
+- Data->Extract.ExtractCurrentFile(&Data->Cmd,Data->Arc,Data->HeaderSize,Repeat);
+-
++
++ if(Data->Extract.ExtractCurrentFile(&Data->Cmd,Data->Arc,Data->HeaderSize,Repeat) == false)
++ return (ERAR_UNKNOWN);
++
+ while (Data->Arc.ReadHeader()!=0 && Data->Arc.GetHeaderType()==NEWSUB_HEAD)
+ {
+ Data->Extract.ExtractCurrentFile(&Data->Cmd,Data->Arc,Data->HeaderSize,Repeat);