aboutsummaryrefslogtreecommitdiff
path: root/archivers/lzfse
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2016-07-07 13:55:20 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2016-07-07 13:55:20 +0000
commit5383ae09db51beea73d140297999cf7abfd03ccf (patch)
treed742e3af7adc2efe258ec7f08272ef09e22d3814 /archivers/lzfse
parent584e5fd0d239de2fb8c3a72cd34f8006b38dba7f (diff)
downloadports-5383ae09db51beea73d140297999cf7abfd03ccf.tar.gz
ports-5383ae09db51beea73d140297999cf7abfd03ccf.zip
This is a reference C implementation of the LZFSE compressor introduced in the
Compression library with OS X 10.11 and iOS 9. LZFSE is a Lempel-Ziv style data compression algorithm using Finite State Entropy coding. It targets similar compression rates at higher compression and decompression speed compared to deflate using zlib. WWW: https://github.com/lzfse/lzfse
Notes
Notes: svn path=/head/; revision=418183
Diffstat (limited to 'archivers/lzfse')
-rw-r--r--archivers/lzfse/Makefile18
-rw-r--r--archivers/lzfse/distinfo3
-rw-r--r--archivers/lzfse/pkg-descr8
-rw-r--r--archivers/lzfse/pkg-plist4
4 files changed, 33 insertions, 0 deletions
diff --git a/archivers/lzfse/Makefile b/archivers/lzfse/Makefile
new file mode 100644
index 000000000000..85bf61caa54b
--- /dev/null
+++ b/archivers/lzfse/Makefile
@@ -0,0 +1,18 @@
+# Created by: Steven Kreuzer <skreuzer@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= lzfse
+PORTVERSION= 20160707
+CATEGORIES= archivers
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Lempel-Ziv style data compression algorithm
+
+USE_GITHUB= yes
+GH_ACCOUNT= lzfse
+GH_TAGNAME= 4591228
+
+USES= gmake
+MAKE_ARGS+= INSTALL_PREFIX="${STAGEDIR}${PREFIX}"
+
+.include <bsd.port.mk>
diff --git a/archivers/lzfse/distinfo b/archivers/lzfse/distinfo
new file mode 100644
index 000000000000..70683c1203fa
--- /dev/null
+++ b/archivers/lzfse/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1467897116
+SHA256 (lzfse-lzfse-20160707-4591228_GH0.tar.gz) = a6b8609947ed610d52f8438ad67c3fd6589f0ae831feae2ef10c2cfc2568d11f
+SIZE (lzfse-lzfse-20160707-4591228_GH0.tar.gz) = 45414
diff --git a/archivers/lzfse/pkg-descr b/archivers/lzfse/pkg-descr
new file mode 100644
index 000000000000..9ce941a620b4
--- /dev/null
+++ b/archivers/lzfse/pkg-descr
@@ -0,0 +1,8 @@
+This is a reference C implementation of the LZFSE compressor introduced in the
+Compression library with OS X 10.11 and iOS 9.
+
+LZFSE is a Lempel-Ziv style data compression algorithm using Finite State
+Entropy coding. It targets similar compression rates at higher compression and
+decompression speed compared to deflate using zlib.
+
+WWW: https://github.com/lzfse/lzfse
diff --git a/archivers/lzfse/pkg-plist b/archivers/lzfse/pkg-plist
new file mode 100644
index 000000000000..7e136d7208bd
--- /dev/null
+++ b/archivers/lzfse/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+include/lzfse.h
+lib/liblzfse.a
+bin/lzfse